September 27, 2011 10:03AM
Sergey A. Osokin Wrote:
-------------------------------------------------------
> On Tue, Sep 27, 2011 at 05:35:57AM -0400,
> springbok wrote:
> > Ok, I've got passenger loading and appearing in
> the process list, I
> > created a index.html file and was able to
> display it doing a GET / but
> > when I try GET / HTTP/1.0 it just sits there and
> nothing happens. If I
> > remove the index.html I get "Hello world"
> returned, no mention of
> > passenger.
>
> So, if you got "Hello, <b>world</b> this means
> passenger works well with
> default installation. Could you please check your
> application or try to use
> previous version of nginx and/or passenger.
>
> --
> Sergey A. Osokin
> osa@FreeBSD.ORG.ru
> osa@FreeBSD.ORG
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://mailman.nginx.org/mailman/listinfo/nginx

Hi Sergey,

I was using 0.8.53 when I started getting the errors and decided to upgrade before posting my question.

Do you believe this is an nginx or passenger problem, is nginx causing passenger to shutdown or the other way around? To me it looks like the watchdog process is getting an error from nginx and closing the passenger processes.

We have 8GB of memory and 4 processors, do you think it could be memory related/CPU load related, I know it's difficult to say without seeing our app and the load it places on the system, but if you had to guess? It has plenty of memory available so I don't think that's a problem, the IT manager for the client which I developed the app is convinced the shutdown is caused by CPU load. When monitoring the load the passenger processes spike up to around 50-80% but settle down to 10% of less when idling, at the moment they are < 1% as the load is low. The shutdown has happened when there is not a lot of load so I'm not convinced.

I just really don't know where to start looking, could it be something external for example the DB the app uses is running on a different server maybe it's a network problem, what about rogue messages is that possible, the IT manager did say he removed the firewall to the machine. I'm sure he has something else in place, but this app has been running fine for the last 6 months, it only started happening after the weekend when we went live and the DB was moved from the same machine to another.

Sorry for all the questions but I'm really stumped and don't know what to try next.

Thanks again for your help.

Etienne.
Subject Author Posted

Nginx and/or Passenger failing

springbok September 27, 2011 03:54AM

Re: Nginx and/or Passenger failing

Sergey A. Osokin September 27, 2011 04:22AM

Re: Nginx and/or Passenger failing

springbok September 27, 2011 04:56AM

Re: Nginx and/or Passenger failing

springbok September 27, 2011 05:10AM

Re: Nginx and/or Passenger failing

springbok September 27, 2011 05:35AM

Re: Nginx and/or Passenger failing

Sergey A. Osokin September 27, 2011 07:02AM

Re: Nginx and/or Passenger failing

springbok September 27, 2011 10:03AM

Re: Nginx and/or Passenger failing

Sergey A. Osokin September 27, 2011 11:40AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 73
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready