Welcome! Log In Create A New Profile

Advanced

Re: Unable to use multiple IPs with SSL (0.7.64)

October 20, 2010 06:20AM
On Wed, Oct 20, 2010 at 06:00:38AM -0400, danjac wrote:

> I have an nginx (v0.7.64) configuration that requires a number of
> virtual hosts each with their own SSL.
>
> I have assigned different IP addresses to each vhost. All IP addresses
> are available on port 443 (i.e. they are not blocked by firewall). All
> certificates are from Thawte.
>
> When I test nginx configuration (nginx -t), I get the following error:
>
> [quote]the configuration file /usr/local/nginx/conf/nginx.conf syntax is
> ok
> [emerg]: bind() to IP1:443 failed (99: Cannot assign requested address)
> configuration file /usr/local/nginx/conf/nginx.conf test failed[/quote]
>
> (where IP1 is one of our IP addresses)

Are you sure that IP1 is configured on this host ?
This error means that there is no such address.

It's better to rewrite this:

> server {
> listen 843;
> server_name localhost;
>
> location / {
> rewrite ^(.*)$ /crossdomain.xml;
> }
>
> error_page 400 /crossdomain.xml;
>
> location /crossdomain.xml {
> root /var/www/html;
> }
> }

as

server {
listen 843;
server_name localhost;

location = / {
alias /var/www/html/crossdomain.xml;
}

error_page 400 /crossdomain.xml;

location = /crossdomain.xml {
root /var/www/html;
}
}


--
Igor Sysoev
http://sysoev.ru/en/

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 06:00AM

Re: Unable to use multiple IPs with SSL (0.7.64)

vesperto October 20, 2010 06:20AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 06:45AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 06:20AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 06:22AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 06:48AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 07:15AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 07:52AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 08:32AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 08:46AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 09:09AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 20, 2010 09:28AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 21, 2010 07:53AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 21, 2010 08:54AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 08:44AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 20, 2010 09:22AM

Re: Unable to use multiple IPs with SSL (0.7.64)

Igor Sysoev October 21, 2010 08:46AM

Re: Unable to use multiple IPs with SSL (0.7.64)

danjac October 21, 2010 07:21PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 51
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready