Welcome! Log In Create A New Profile


How to disable keepalive_requests

Posted by ramarov 
How to disable keepalive_requests
December 14, 2022 01:45AM

We recently upgraded our nginx version from 1.19.6 to 1.19.10. After the upgrade user async HTTP request failing. I understand from https://kubernetes.github.io/ingress-nginx/user-guide/nginx-configuration/configmap/#keep-alive from version 1.19.7 nginx uses keepalive directives.

User connection closed I think after reaches the max number of request from keepalive_requests. Is it possible to configure nginx not to close TCP connection based on number of HTTP requests? I would like the connection open as long client is active or keep the connection alive atleast as per the keepalive_time directives.

How we can disable keepalive_requests in nginx so the nginx don't use this directive to determine when to close the keepalive connection?

Thank you in advance.

Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 339
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready