Welcome! Log In Create A New Profile


autoindex on - 404 not found

Posted by R8kid 
autoindex on - 404 not found
November 07, 2018 06:44PM
Hi all,

I installed nginx on an offline computer, I configured it
and it worked fine. But when I installed nginx as a service
with NSSM, autoindex does not work, I get an 404 error
message, I can't access any html page but the php pages
are working fine.

When I run nginx normally in the command prompt, not
as a service, everything works fine again, but when I run
nginx as a service, I get an 404 error message.

Can anyone please help me with this issue?

Thanks in advance.
Re: autoindex on - 404 not found
November 08, 2018 10:12AM
If it runs as a service that service needs access rights to whereever your data is.

nginx for Windows http://nginx-win.ecsds.eu/
Re: autoindex on - 404 not found
November 09, 2018 05:08AM
Thanks for your reply. I forgot to mention that I was
trying to access mapped networking drives. After I
tried everything I know I still could not make it work,
so I decided to write a small C# program to
start / stop / reload the nginx server in the system
tray and I added that program to start up.

Edited 1 time(s). Last edit at 11/09/2018 05:10AM by R8kid.
Re: autoindex on - 404 not found
November 09, 2018 05:45AM
Just use srvany to create a service and use a .cmd file, in there you can 'net use' and start nginx.

nginx for Windows http://nginx-win.ecsds.eu/
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 319
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 500 on July 15, 2024
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready