Welcome! Log In Create A New Profile

Advanced

default server function not working

Posted by nephilim75 
default server function not working
September 25, 2016 05:18AM
Hello

I am facing an issue that I cannot get fixed. I am looking for some assistance.

I try to run more than one service on my nginx server (on raspi). The default service I would like to serve is a WordPress installation which is coming up when I call https://sub.domain.com:port.
The second one should be served once I call https://sub.domain.com:port/service. This one is working well already.

I created 2 server blocks in /etc/nginx/sites-available. One is called wordpress and the second one is called service. Both are enabled in /etc/nginx/sites-enabled by symlink.

The wordpress config you'll find here: http://pastebin.ubuntu.com/23228439/
The service config you'll find here: http://pastebin.ubuntu.com/23228447/

Once I call https://sub.domain.com:port I receive the "welcome to nginx on debian" screen. I have deleted the default server block and I have removed the html which includes this welcome page. It doesn't matter, I still receive this page and not my WordPress installation. I restarted the nginx service more than one time. No effect.

I marked the Wordpress server block as default server but it doesn't work.

Any idea what I did wrong or I missed to set?

Kind regards
Re: default server function not working
September 25, 2016 11:11AM
[Solved]

Found a solution. Problem was a domain address conflict.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 293
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready