Welcome! Log In Create A New Profile

Advanced

Create_File error

Posted by MySchizoBuddy 
Create_File error
September 14, 2009 06:10PM
I'm getting this error
[code]
2009/09/15 03:47:30 [error] 2072#3228: *1 CreateFile() "C:\nginx/html/flow3/Web/index.php/flow3/welcome" failed (3: The system cannot find the path specified), client: 127.0.0.1, server: dev.flow3.local, request: "GET /flow3/welcome HTTP/1.1", host: "dev.flow3.local"
[/code]

its correct there is no file called flow3/welcome.
flow3 and welcome are parameters that are fed to index.php. it shouldn't be looking for them. the flow3 framework will deal with the parameters

here is nginx.conf
[code]

#user nobody;
worker_processes 1;

error_log logs\error.log;
#error_log logs/error.log notice;
#error_log logs/error.log info;

pid logs/nginx.pid;


events {
worker_connections 1024;
}


http {
include mime.types;
default_type application/octet-stream;

log_format main '$remote_addr - $remote_user [$time_local] "$request" '
'$status $body_bytes_sent "$http_referer" '
'"$http_user_agent" "$http_x_forwarded_for"';

#access_log logs/access.log main;

sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 100;

gzip on;
gzip_comp_level 9;

server {
listen 80;
server_name localhost;

#charset koi8-r;

#access_log logs/host.access.log main;

location / {
root html;
index index.php index.html index.htm;
}

#error_page 404 /404.html;

# redirect server error pages to the static page /50x.html
#
error_page 500 502 503 504 /50x.html;
location = /50x.html {
root html;
}

# proxy the PHP scripts to Apache listening on 127.0.0.1:80
#
#location ~ \.php$ {
# proxy_pass http://127.0.0.1;
#}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
location ~ \.php$ {
root html;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME html$fastcgi_script_name;
include fastcgi_params;

}

# deny access to .htaccess files, if Apache's document root
# concurs with nginx's one
#
#location ~ /\.ht {
# deny all;
#}
}
server {
listen 80;
server_name dev.flow3.local;

location / {
root html/flow3/Web;
index index.php index.html index.htm;

if (!-e $request_filename) {
rewrite /(.*) /index.php/$1;
break;
}
}

error_page 500 502 503 504 /50x.html;
location = /50x.html {
root html;
}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
location ~ \.php$ {
fastcgi_connect_timeout 60;
fastcgi_send_timeout 180;
fastcgi_read_timeout 180;
fastcgi_buffer_size 128k;
fastcgi_buffers 4 256k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
fastcgi_intercept_errors on;

root html/flow3/Web;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME html/flow3/Web$fastcgi_script_name;
include fastcgi_params;

expires max;
}

location ~ /\.ht {
deny all;
}
}

}

[/code]
Re: Create_File error
September 14, 2009 07:40PM
i had the same error appear in apache. turns out mod_rewrite was disabled
How Do i enable the rewrite module on nginx. It says in the documentation that it comes preinstalled
I'm using the nginx 0.8.15
Re: Create_File error
September 15, 2009 12:12AM
It is pre-installed unless it was disabled during configuration.

If you compiled it yourself and didn't disable it then it's there.

If not, run

C:\> nginx -V

to see the exact configuration. I assume this works in Windows - it does in Linux and FreeBSD - but you may need to put in the full path to the binary.

--
Jim Ohlstein
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 109
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready