Welcome! Log In Create A New Profile


no "charset_map" between the charsets "iso-8859-1" and "UTF-8"

Posted by nadav123 
no "charset_map" between the charsets "iso-8859-1" and "UTF-8"
June 15, 2021 03:15AM
Hey, how are you guys?
facing a charset map issue, I tried everything, even override in Apache but is not work.
the only way I get rid of the charset, is if I put this code in the nginx.conf:

## Charset ##
charset utf-8;
override_charset on;
charset_map iso-8859-1 utf-8 { }

but when I run: curl -I -L locksmithunit.com
the charset gone completely in HTTP version.
this isiue couse SEO drop, the IP in my error log belong to GOOGLE:

2021/06/15 01:07:31 [error] 6271#6271: *4786 no "charset_map" between the charsets "iso-8859-1" and "UTF-8" while reading response header from upstream, client: ::ffff:, server: localhost, request: "GET /sitemap_index.xml HTTP/1.1", subrequest: "/sitemap_index.xml", upstream: "", host: "locksmithunit.cat"

the funny thing when I put charset UTF-8 in APACHE and get more errors from Nginx...
I believe I need the full charset_map and not put it empty like this:
charset_map iso-8859-1 utf-8 { }

If someone here knows the right charset_map? Because i didn't find that anywhere...

I found a couple but none of them is not iso-8859-1:

if someone knows the right charset_map is been very very helpful to google crawlers.
Re: no "charset_map" between the charsets "iso-8859-1" and "UTF-8"
August 09, 2021 10:15AM
No help? someone?
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 358
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 466 on July 09, 2024
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready