Welcome! Log In Create A New Profile

Advanced

reverse-proxy configuration issue when running from different browsers

Posted by richpuerto 
reverse-proxy configuration issue when running from different browsers
February 12, 2024 08:48PM
Hello,

I kindly request help in how to resolve the following problem I am experiencing on my new nginx server configuration.

Basic information:
Installed Nginx ver 1.8 on Ubuntu 20.04 LTS
Objective: to use Nginx as a reverse-proxy server.
I host my own sites, one public IP.

I have two webservers on my internal network.
All http and https traffic is natting to my Nginx server
Nginx Reverse-proxy, passes traffic to specific webserver depending on domain-name (domain-name.conf)
domain-name.conf resides in /etc/nginx/sites-enabled (see attached file)

Problem:

My installation is partially working.
For example the attached .conf works well when using Firefox, but when using Safari or Chrome, it does not work.

Other situation I am experiencing is with another similar .conf file for another domain-name (same file as attached but different servername, ssl path, and proxy-pass IP)
It works well when using Safari and Chrome but it does not well when using Firefox.

Any suggestions to correct this problem?

Thanks.

Rich
Attachments:
open | download - Nginx domain_name.conf (example file).rtf (2.2 KB)
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 270
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready