Yichun Zhang (agentzh)
October 05, 2015 11:02PM
Hello!

On Wed, Sep 23, 2015 at 1:14 AM, Carlos Eduardo Ferreira Rodrigues wrote:
> I just upgraded nginx to 1.9.5 on our testing enviroment, and immediately started seeing this error on http2 requests:
>
> 2015/09/22 18:04:06 [alert] 27305#27305: *1 epoll_ctl(1, 17) failed (17: File exists), client: x.x.x.x, server: _, request: "GET ... HTTP/2.0", subrequest: "...", host: "..."
>
> The subrequest is being made from Lua code using "ngx.location.capture()", so I understand this may be an issue with ngx_lua and not nginx itself. However, this worked fine with nginx 1.8.0/1.9.4 and spdy and nothing else has changed.
>

The ngx.location.capture* API does not support SPDY nor HTTP 2.0
(yet). We may add such support in the future.

Oh, BTW, nginx 1.9.5 is not listed in the compatible nginx core list yet:

https://github.com/openresty/lua-nginx-module#nginx-compatibility

Regards,
-agentzh

_______________________________________________
nginx-devel mailing list
nginx-devel@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx-devel
Subject Author Views Posted

subrequest error with http2

Carlos Eduardo Ferreira Rodrigues 1552 September 22, 2015 01:16PM

Re: subrequest error with http2

Maxim Dounin 651 September 22, 2015 01:36PM

Re: subrequest error with http2

itpp2012 1292 September 22, 2015 02:20PM

Re: subrequest error with http2

Yichun Zhang (agentzh) 552 October 05, 2015 11:06PM

Re: subrequest error with http2

Yichun Zhang (agentzh) 546 October 05, 2015 11:02PM

RE: subrequest error with http2

Carlos Eduardo Ferreira Rodrigues 675 October 06, 2015 05:34AM

Re: subrequest error with http2

Yichun Zhang (agentzh) 598 October 07, 2015 05:44AM



Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 63
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready