Welcome! Log In Create A New Profile

Advanced

php-fpm на Debian (Lenny) Проблема с установкой

Posted by Maxmoriss 
Приветствую! Вот уже битый вечер сижу и пытаюсь установить на сервер
nginx+php-fpm, перелопатил кучу мануалов, но как только дело доходит
до установки собственно php-fpm, дело останавливается.

lizzy:~# aptitude install php5-fpm php5-cgi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
No candidate version found for php5-fpm
No candidate version found for php5-fpm
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 51 not
upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

До этого пробовал apt-get,

lizzy:~# apt-get install php5-fpm php5-cgi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-fpm is not available, but is referred to by another
package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package php5-fpm has no installation candidate

В чем коварство? Буду признателен за помощь!
Поиск на packages.debian.org подсказывает, что пакет php5-fpm есть только в
sid / unstable: http://packages.debian.org/sid/php5-fpm

2011/2/27 Maxmoriss <maxmoriss@gmail.com>

> Приветствую! Вот уже битый вечер сижу и пытаюсь установить на сервер
> nginx+php-fpm, перелопатил кучу мануалов, но как только дело доходит
> до установки собственно php-fpm, дело останавливается.
>
> lizzy:~# aptitude install php5-fpm php5-cgi
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Reading extended state information
> Initializing package states... Done
> No candidate version found for php5-fpm
> No candidate version found for php5-fpm
> No packages will be installed, upgraded, or removed.
> 0 packages upgraded, 0 newly installed, 0 to remove and 51 not
> upgraded.
> Need to get 0B of archives. After unpacking 0B will be used.
> Writing extended state information... Done
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Reading extended state information
> Initializing package states... Done
>
> До этого пробовал apt-get,
>
> lizzy:~# apt-get install php5-fpm php5-cgi
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package php5-fpm is not available, but is referred to by another
> package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> E: Package php5-fpm has no installation candidate
>
> В чем коварство? Буду признателен за помощь!




--
Best regards,
Bruce Weirdan mailto:
weirdan@gmail.com
Приветствую

27 февраля 2011 г. 22:51 пользователь Maxmoriss <maxmoriss@gmail.com> написал:
> Приветствую! Вот уже битый вечер сижу и пытаюсь установить на сервер
> nginx+php-fpm, перелопатил кучу мануалов, но как только дело доходит
> до установки собственно php-fpm, дело останавливается.
....
> В чем коварство? Буду признателен за помощь!

Потому что в в офф. сборке php5 нету fpm.

#apt-cache policy php5-fpm
php5-fpm:
Установлен: 5.3.5-0.dotdeb.0
Кандидат: 5.3.5-0.dotdeb.0
Таблица версий:
*** 5.3.5-0.dotdeb.0 0
100 /var/lib/dpkg/status

Используйте dotdeb http://www.dotdeb.org/instructions/







--
Have a nice day
Да, я в курсе что в пакетах Debian Lenny php-fpm отсутствует, для того
что-бы это обойти вручную обновлял cource lists,

Вот например так это делается в одном из мануалов,

echo "deb http://backports.debian.org/debian-backports lenny-backports main"
> >> /etc/apt/sources.list && aptitude update
> aptitude install -t lenny-backports "nginx"
> echo "deb http://php53.dotdeb.org stable all" >> /etc/apt/sources.list &&
> aptitude update
> aptitude install php5-cli php5-common php5-suhosin
> aptitude install php5-fpm php5-cgi



2011/2/28 Weirdan <weirdan@gmail.com>

> Поиск на packages.debian.org подсказывает, что пакет php5-fpm есть только
> в sid / unstable: http://packages.debian.org/sid/php5-fpm
>
> 2011/2/27 Maxmoriss <maxmoriss@gmail.com>
>
> Приветствую! Вот уже битый вечер сижу и пытаюсь установить на сервер
>> nginx+php-fpm, перелопатил кучу мануалов, но как только дело доходит
>> до установки собственно php-fpm, дело останавливается.
>>
>> lizzy:~# aptitude install php5-fpm php5-cgi
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> Reading extended state information
>> Initializing package states... Done
>> No candidate version found for php5-fpm
>> No candidate version found for php5-fpm
>> No packages will be installed, upgraded, or removed.
>> 0 packages upgraded, 0 newly installed, 0 to remove and 51 not
>> upgraded.
>> Need to get 0B of archives. After unpacking 0B will be used.
>> Writing extended state information... Done
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> Reading extended state information
>> Initializing package states... Done
>>
>> До этого пробовал apt-get,
>>
>> lizzy:~# apt-get install php5-fpm php5-cgi
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> Package php5-fpm is not available, but is referred to by another
>> package.
>> This may mean that the package is missing, has been obsoleted, or
>> is only available from another source
>> E: Package php5-fpm has no installation candidate
>>
>> В чем коварство? Буду признателен за помощь!
>
>
>
>
> --
> Best regards,
> Bruce Weirdan mailto:
> weirdan@gmail.com
>



--
С Уважением,
Морозов Максим.
2011/2/28 Maxmoriss <maxmoriss@gmail.com>

> Да, я в курсе что в пакетах Debian Lenny php-fpm отсутствует, для того
> что-бы это обойти вручную обновлял cource lists,


Ну покажите свой sources.list - вряд ли кто догадается, как именно вы его
изменили.


--
Best regards,
Bruce Weirdan mailto:
weirdan@gmail.com
2011/2/28 Weirdan <weirdan@gmail.com>

>
>
> 2011/2/28 Maxmoriss <maxmoriss@gmail.com>
>
> Да, я в курсе что в пакетах Debian Lenny php-fpm отсутствует, для того
>> что-бы это обойти вручную обновлял cource lists,
>
>
> Ну покажите свой sources.list - вряд ли кто догадается, как именно вы его
> изменили.


И еще глупый вопрос вдогонку - sudo aptitude update / sudo apt-get update
после изменения sources.list выполнили?


--
Best regards,
Bruce Weirdan mailto:
weirdan@gmail.com
А вот теперь проясняется - похоже вы пытаетесь ставить пакеты из stable на
lenny. stable уже почти месяц как squeeze.

Попробуйте
deb http://php53.dotdeb.org oldstable all
# или deb http://php53.dotdeb.org lenny all

список пакетов на php53.dotdeb.org для stable вообще пустой на данный
момент.

--
Best regards,
Bruce Weirdan mailto:
weirdan@gmail.com
/etc/apt/sources.list

#deb http://ftp.de.debian.org/debian-volatile lenny/volatile main contrib
non-free
deb ftp://mirror.hetzner.de/debian/packages lenny main contrib
non-free
deb ftp://mirror.hetzner.de/debian/security lenny/updates main contrib
non-free

deb http://backports.debian.org/debian-backports lenny-backports main
deb http://php53.dotdeb.org stable all
deb http://backports.debian.org/debian-backports lenny-backports main
deb http://php53.dotdeb.org stable all
deb http://backports.debian.org/debian-backports lenny-backports main
deb http://php53.dotdeb.org stable all

sudo aptitude update / sudo apt-get update - делал разумеется.

2011/2/28 Weirdan <weirdan@gmail.com>

>
>
> 2011/2/28 Weirdan <weirdan@gmail.com>
>
>>
>>
>> 2011/2/28 Maxmoriss <maxmoriss@gmail.com>
>>
>> Да, я в курсе что в пакетах Debian Lenny php-fpm отсутствует, для того
>>> что-бы это обойти вручную обновлял cource lists,
>>
>>
>> Ну покажите свой sources.list - вряд ли кто догадается, как именно вы его
>> изменили.
>>
>
> И еще глупый вопрос вдогонку - sudo aptitude update / sudo apt-get update
> после изменения sources.list выполнили?
>
>
> --
> Best regards,
> Bruce Weirdan mailto:
> weirdan@gmail.com
>



--
С Уважением,
Морозов Максим.
Точно! После замены на lenny все поставилось! Спасибо!

2011/3/1 Weirdan <weirdan@gmail.com>

> А вот теперь проясняется - похоже вы пытаетесь ставить пакеты из stable на
> lenny. stable уже почти месяц как squeeze.
>
> Попробуйте
> deb http://php53.dotdeb.org oldstable all
> # или deb http://php53.dotdeb.org lenny all
>
> список пакетов на php53.dotdeb.org для stable вообще пустой на данный
> момент.
>
> --
> Best regards,
> Bruce Weirdan mailto:
> weirdan@gmail.com
>



--
С Уважением,
Морозов Максим.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 81
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready