Welcome! Log In Create A New Profile

Advanced

Re: forum <-> ML gateway

April 24, 2010 10:42PM
On 4/24/10 9:19 PM, Maxim Dounin wrote:
> Hello!
>
> On Sat, Apr 24, 2010 at 09:59:46AM -0400, Jim Ohlstein wrote:
>
>> On 4/24/10 9:18 AM, Maxim Dounin wrote:

[...]

>
> I don't really understand how parsing non-Latin characters is
> related to threading. It should be done based on matching
> Message-Id and In-Reply-To/References headers, which are
> ASCII-only.
>
> If it's done based on Subject for some unknown reason - it should
> be just changed to do correct Message-Id/In-Reply-To matching
> instead.
>

I will look into this but it seems only to happen (if memory serves me
correctly) in subjects with a mixture of Latin and Cyrillic characters.
It's not my script and I'm not likely to be able to do a better job with
PHP than the original author. However, I can try. It does not happen in
English forum, or very rarely.


>>> And in some cases messages are actually available in forum but
>>> disappear after reply in forum.
>>
>> Sorry Maxim, but this is impossible. A post can only "disappear" if
>> it is specifically deleted by myself. Sometimes *new* posts and
>
> [...]
>
> Here it is:
>
> http://forum.nginx.org/read.php?21,64648
> http://nginx.org/pipermail/nginx-ru/2010-March/thread.html#33016
>
> The following message was there (and was replied by Sergey in the
> same forum thread), but disappeared after reply:
>
> http://nginx.org/pipermail/nginx-ru/2010-March/033042.html
>
> Here is Sergey's reply:
>
> http://forum.nginx.org/read.php?21,64648,64889#msg-64889
>
> And here is his question ("Strange, your previous post
> disappeared"):
>
> http://forum.nginx.org/read.php?21,64648,64890#msg-64890


I stand corrected. The other way it can happen is if I restore a
database backup. I did on March 17th as I had a problem with a Phorum
upgrade and had to restore a backup. Looking through my email records
that occurred on March 17th. (Looking also at Google, Phorum version
5.2.15 was released that day. I upgraded - there is a thread on my
issues in their support forum which is currently unreachable.) So it's
likely that in the 30-60 minutes that I was working on this a few
messages were indeed lost. The backup that was restored was no older
than that, and was probably closer to 15 minutes old. It's an
overstatement to say that "in some cases messages are actually available
in forum but disappear after reply in forum." This type of thing happens
and is why I follow the good practice to create a backup of the database
and of all files immediately prior to any upgrade. I made an error in
judgement in not stopping the cron job that imports email into the
database every two minutes. Once those emails are imported they are
deleted from the "Maildir" and cannot be recovered. So once I reverted
to the "good" database those entries were gone.

Do you have other examples from other time periods? If so then there are
several possibilities including that someone might have gotten my
password. I have changed it just now.


>
> Maxim Dounin
>
> p.s. And, BTW, another problem which may be seen in the same
> thread and very annoying: forum-to-maillist gateway skips things
> like "[alert]" while they are happily rendered in the forum itself.
> In extreme cases it munges regexps posted via forum to something
> different but still valid.
>
> Most likely it tries to skip bbcodes, but looks like it does it
> wrong and this causes more harm than good. Could you please
> either fix it or just switch off this bbcode removal?

I don't know how "happily" it renders anything. However, the bbcode
stripping in outgoing email is woefully inadequate and will strip
anything enclosed in square brackets. I have disabled this as of now but
it will likely have some undesirable effects.


--
Jim Ohlstein

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

forum <-> ML gateway

Alejandro Mery April 24, 2010 06:10AM

Re: forum <-> ML gateway

Jim Ohlstein April 24, 2010 09:04AM

Re: forum <-> ML gateway

Maxim Dounin April 24, 2010 09:22AM

Re: forum <-> ML gateway

Jim Ohlstein April 24, 2010 10:06AM

Re: forum <-> ML gateway

Maxim Dounin April 24, 2010 09:24PM

Re: forum <-> ML gateway

Jim Ohlstein April 24, 2010 10:42PM

Re: forum <-> ML gateway

Ryan Malayter April 24, 2010 11:54PM

Re: forum <-> ML gateway

Alejandro Mery April 24, 2010 09:44AM

Re: forum <-> ML gateway

Jim Ohlstein April 24, 2010 10:22AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 142
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready