Welcome! Log In Create A New Profile

Advanced

Re: NGINX upload limit

zen zenitram
April 16, 2024 12:12AM
Good day!

Here is the NGINX Configuration, we tried everything but up to now the
upload max limit is still at 128 kb.


*/etc/nginx/nginx.conf*


worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}

http {


# Basic Settings

sendfile on;
tcp_nopush on;
types_hash_max_size 2048;
client_max_body_size 500M;
# server_tokens off;

# server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

##
# SSL Settings
##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3; # Dropping SSLv3, ref:
POODLE
ssl_prefer_server_ciphers on;

##
# Logging Settings
##

access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;

##
# Gzip Settings
##

gzip_vary on;

# gzip_vary on;
# gzip_proxied any;
# gzip_comp_level 6;
# gzip_buffers 16 8k;
# gzip_http_version 1.1;
# gzip_types text/plain text/css application/json
application/javascript text/xml application/xml application/xml+rss
text/javascript;

##
# Virtual Host Configs
##

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;
}





*/etc/nginx/site-available/test.edu.ph http://test.edu.ph*

server {
server_name test.edu.ph;

location / {
proxy_pass https://192.168.8.243;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
client_max_body_size 500M;
}

listen 443 ssl; # managed by Certbot
ssl_certificate /etc/letsencrypt/live/test.edu.ph/fullchain.pem; #
managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/test.edu.ph/privkey.pem; #
managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
client_max_body_size 500M;

}

server {
if ($host = test.edu.ph) {
return 301 https://$host$request_uri;
} # managed by Certbot


listen 80;
server_name test.edu.ph;
return 404; # managed by Certbot
client_max_body_size 500M;
}






Can anyone help us solve our max upload size limit.

Our server is set to https only access.


Thank you!



On Fri, Mar 1, 2024 at 11:27 PM Sergey A. Osokin <osa@freebsd.org.ru> wrote:

> Hi there,
>
> On Fri, Mar 01, 2024 at 04:45:07PM +0800, zen zenitram wrote:
> >
> > We created an institutional repository with eprints and using NGINX as
> load
> > balancer, but we encountered problem in uploading file to our repository.
> > It only alccepts 128 kb file upload, the client_max_body_size is set to 2
> > gb.
> >
> > but still it only accepts 128 kb max upload size.
> > How to solve this problem?
>
> I'd recommend to share the nginx configuration file in the maillist.
> Don't forget to remove any sensitive information or create a minimal
> nginx configuration reproduces the case.
>
> Thank you.
>
> --
> Sergey A. Osokin
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> https://mailman.nginx.org/mailman/listinfo/nginx
>
_______________________________________________
nginx mailing list
nginx@nginx.org
https://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

NGINX upload limit

zen zenitram March 01, 2024 03:46AM

Re: NGINX upload limit

Sergey A. Osokin March 01, 2024 10:28AM

Re: NGINX upload limit

zen zenitram April 16, 2024 12:12AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 335
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready