Welcome! Log In Create A New Profile

Advanced

Debian 12 bookworm error installed package nginx libnginx-mod-http-lua

November 09, 2023 10:41AM
Hello.
In system Linux Debian 12 bookworm, error installed package nginx libnginx-mod-http-lua
Need Lua support in nginx.

My ststem Debian GNU/Linux 12 (bookworm)

# apt search nginx | grep nginx/stable
nginx/stable 1.25.3-1~bookworm amd64
high performance web server

apt search libnginx-mod-http-lua
libnginx-mod-http-lua/stable 1:0.10.23-1 amd64
Lua module for Nginx

Installing packages.

# apt install nginx libnginx-mod-http-lua
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libnginx-mod-http-lua : Depends: libnginx-mod-http-ndk but it is not going to be installed
Depends: nginx-abi-1.22.1-7
E: Unable to correct problems, you have held broken packages.

How to fix?
Subject Author Posted

Debian 12 bookworm error installed package nginx libnginx-mod-http-lua

bagas November 09, 2023 10:41AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 78
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready