Welcome! Log In Create A New Profile

Advanced

Re: nginx and php settings

Ian Hobson
March 14, 2020 06:58AM
Hi Mamood,

On 14/03/2020 08:09, Mahmood Naderan wrote:
> Hi,
> I have install nginx 1.0.15 and php 5.3 on a VM running Ubuntu 14.04.
> The configuration file looks like below
>
> $ cat /usr/local/nginx/conf/nginx.conf
> #user  nobody;
> worker_processes  1;
> #error_log  logs/error.log;
> #error_log  logs/error.log  notice;
> #error_log  logs/error.log  info;
> #pid        logs/nginx.pid;
> events {
>     worker_connections  1024;
> }
> http {
>     include       mime.types;
>     default_type  application/octet-stream;
>     #log_format  main  '$remote_addr - $remote_user [$time_local]
> "$request" '
>     #                  '$status $body_bytes_sent "$http_referer" '
>     #                  '"$http_user_agent" "$http_x_forwarded_for"';
>
>     #access_log  logs/access.log  main;
>     sendfile        on;
>     #tcp_nopush     on;
>     #keepalive_timeout  0;
>     keepalive_timeout  65;
>     #gzip  on;
>     server {
>         listen       80;
>         server_name  localhost;
>         #charset koi8-r;
>         #access_log  logs/host.access.log  main;
>         location / {
>             root   html;
This is not the same as below.
>             index  index.html index.htm;
>         }
>         #error_page  404              /404.html;
>         # redirect server error pages to the static page /50x.html
>         #
>         error_page   500 502 503 504  /50x.html;
>         location = /50x.html {
>             root   html;
>         }
>         # proxy the PHP scripts to Apache listening on 127.0.0.1:80
> http://127.0.0.1:80
>         #
>         #location ~ \.php$ {
>         #    proxy_pass http://127.0.0.1;
>         #}
>         # pass the PHP scripts to FastCGI server listening on
> 127.0.0.1:9000 http://127.0.0.1:9000
>         #
>         location ~ \.php$ {
>             root           html;
>             fastcgi_pass 127.0.0.1:9000 http://127.0.0.1:9000;
>             fastcgi_index  index.php;
>             fastcgi_param  SCRIPT_FILENAME
>  /usr/local/nginx/html/public_html/$fastcgi_script_name;

I think you need to remove the public_html/ part of this. I would expect
the line to be
fastcgi_param SCRIPT_FILENAME /usr/local/nginx/html/$fastcgi_script_name;

Other things to check are:
1) Does the fastcgi process (probably user www-data) have permission to
read your phpinfo.php file?

2) Uncomment the error-log lines near the top, and choose a suitable
level of logging, and then check the error-log
after the problem.

Hope this helps.

Ian

<snip>
>
> I also have put a phpinfo.php file like this
>
> root@fr13:/usr/local/nginx/html# cat phpinfo.php
> <?php phpinfo(); ?>
>
>
> When I open the browser and enter localhost/phpinfo.php, I get this message
>
> The page you are looking for is temporarily unavailable.
> Please try again later.
>

--
This email has been checked for viruses by AVG.
https://www.avg.com

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

nginx and php settings

Mahmood Naderan March 14, 2020 04:12AM

Re: nginx and php settings

Ian Hobson March 14, 2020 06:58AM

Re: nginx and php settings

Mahmood Naderan March 14, 2020 08:26AM

Re: nginx and php settings

Mahmood Naderan March 15, 2020 08:22AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 53
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready