Welcome! Log In Create A New Profile

Advanced

enable reuseport then only one worker is working?

February 28, 2016 08:52AM
Hi All,

I just upgrade Nginx from 1.8 o 1.9 on my FreeBSD box.
After I enabled reuseport on my server, it seems now there is one worker always takes up 100% CPU and all the rest workers are use less than 1% CPU. In the day time it's OK because my website doesn't have lots of users. But at night it's very slow.

Active connections: 5716
server accepts handled requests
175477 175477 1805645
Reading: 1 Writing: 698 Waiting: 5541

After I disable reuseport, it seems my website speed is back to normal. Each worker (18 workers in total) takes up about 10%-15% CPU.

I understand that enable reuseport will disable accept_mutex. But My understanding is that Nginx will assign work load to different multiple socket listeners then to different workers. BUt it seems in my environment all workload was assign to the same worker, even though it's very busy and the rest are idle.

Did I miss anything in the configuration? or for a busy server, it's better to use accept_mutex instead of reuseport?
Subject Author Posted

enable reuseport then only one worker is working?

meteor8488 February 28, 2016 08:52AM

Re: enable reuseport then only one worker is working?

Валентин Бартенев February 28, 2016 11:24PM

Re: enable reuseport then only one worker is working?

Jim Ohlstein March 01, 2016 08:12AM

Re: enable reuseport then only one worker is working?

Andrew Hutchings March 01, 2016 08:36AM

Re: enable reuseport then only one worker is working?

Jim Ohlstein March 01, 2016 09:24AM

Re: enable reuseport then only one worker is working?

Maxim Konovalov March 01, 2016 09:36AM

Re: enable reuseport then only one worker is working?

Jim Ohlstein March 01, 2016 12:20PM

Re: enable reuseport then only one worker is working?

Maxim Konovalov March 01, 2016 12:28PM

Re: enable reuseport then only one worker is working?

Jim Ohlstein March 01, 2016 12:52PM

Re: enable reuseport then only one worker is working?

Maxim Konovalov March 01, 2016 12:56PM

Re: enable reuseport then only one worker is working?

Andrew Hutchings March 01, 2016 09:44AM

Re: enable reuseport then only one worker is working?

Maxim Dounin February 29, 2016 09:08AM

Re: enable reuseport then only one worker is working?

drhowarddrfine March 01, 2016 07:46AM

Re: enable reuseport then only one worker is working?

Maxim Konovalov March 01, 2016 07:54AM

Re: enable reuseport then only one worker is working?

drhowarddrfine March 01, 2016 08:08AM

Re: enable reuseport then only one worker is working?

Maxim Konovalov March 01, 2016 08:14AM

Re: enable reuseport then only one worker is working?

drhowarddrfine March 01, 2016 08:32AM

Re: enable reuseport then only one worker is working?

Valentin V. Bartenev March 01, 2016 08:36AM

Re: enable reuseport then only one worker is working?

meteor8488 March 01, 2016 07:13PM

Re: enable reuseport then only one worker is working?

Andrew Hutchings March 02, 2016 03:40AM

Re: enable reuseport then only one worker is working?

meteor8488 January 27, 2017 11:02PM

Re: enable reuseport then only one worker is working?

Maxim Konovalov January 28, 2017 05:32AM

Re: enable reuseport then only one worker is working?

meteor8488 February 02, 2017 07:41PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 82
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready