Welcome! Log In Create A New Profile

Advanced

Re: Problem with NGINX on MIPS processor

Maxim Dounin
August 03, 2015 02:04PM
Hello!

On Mon, Aug 03, 2015 at 08:44:52AM -0400, mynidiravichandra wrote:

> Hi,
> I am trying to run nginx on a MIPS processor. In my NGINX server
> configuration, i have used only worker process. When i try connecting with
> openssl s_client application, i am able to connect only once. After this,
> the first connection is closed and if i try connecting again, server doesn't
> accept any connection. I have tried strace on the nginx server process and
> observed that worker process in busy in writing some data to the
> closed(first) connection.
>
> PS: i have tried the same experiment on x86 and didn't face any such issue.
>
> Appreciate any help/suggestions regarding this issue.

First of all I would recommend to try plain HTTP, without SSL.
This may be some SSL related problem, either in nginx or in
OpenSSL itself.

--
Maxim Dounin
http://nginx.org/

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Problem with NGINX on MIPS processor

mynidiravichandra August 03, 2015 08:44AM

Re: Problem with NGINX on MIPS processor

Maxim Dounin August 03, 2015 02:04PM

Re: Problem with NGINX on MIPS processor

mynidiravichandra August 06, 2015 03:03AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 264
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready