Welcome! Log In Create A New Profile

Advanced

remote server static content is not getting loaded

July 12, 2015 05:09PM
Hi,

ISSUE: Static content is not loaded from remote server where application is deployed, rather it is reading from the server where NGinx is installed.
-------------------------------------------------------

Nginx-1.8.0 is installed (on the server nginx.corp.stel.no)

Proxy pass to another server (workspace.corp.stel.no) for an webrequest

Below configurations made:

server {
listen 80;
server_name workspace.corp.stel.no;

location /{
proxy_pass http://stelworkspace/workspace/agentLogin/;
}

location ~* \.(js|jpg|png|css|woff|svg|gif|eot|ttf)$ {
root /var/gvp/Nginx/nginx-1.8.0/ser_static_info;
expires 30d;
}
}

This is reading data from local Nginx server (nginx.corp.test.no) and not from the remote server (workspace.corp.stel.no) where application is deployed

Tried below option too..

location ~"*\.(js|jpg|png|css)$" {
root http://workspace123/workspace/;
expires 30d;
}

Nothing seems working

Pls. assist here? If given an example...would be appreciated


Best regards,
Maddy
Subject Author Posted

remote server static content is not getting loaded

smsmaddy1981 July 12, 2015 05:09PM

Re: remote server static content is not getting loaded

Francis Daly July 12, 2015 05:46PM

Re: remote server static content is not getting loaded

smsmaddy1981 August 01, 2015 07:33PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 69
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready