Welcome! Log In Create A New Profile

Advanced

Re: Subdomains no longer work

December 09, 2013 08:24AM
One problem seems to be that it is not possible to stop nginx:

sudo /etc/init.d/nginx stop
[ ok ] Stopping nginx: nginx.
~$ ps ax -o pid,ppid,%cpu,vsz,wchan,command|egrep '(nginx|PID)'
PID PPID %CPU VSZ WCHAN COMMAND
23558 1 0.0 123844 ep_pol nginx: cache manager process
24945 22802 0.0 6392 pipe_w egrep (nginx|PID)
27042 1 0.0 127780 ep_pol nginx: worker process
27043 1 0.0 127756 ep_pol nginx: worker process
27045 1 0.0 127640 ep_pol nginx: worker process
27046 1 0.0 127636 ep_pol nginx: worker process
27048 1 0.0 123952 ep_pol nginx: cache manager process

Only PID 27041 gets killed.


curl -v http://www.domain.tld/test
* About to connect() to www.domain.tld port 80
* Trying 1.2.3.4... connected
* Connected to www.domain.tld (1.2.3.4) port 80
> GET /test HTTP/1.1
> User-Agent: curl/7.15.5 (x86_64-pc-linux-gnu) libcurl/7.15.5 OpenSSL/0.9.8c zlib/1.2.3 libidn/0.6.5
> Host: www.domain.tld
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
< Server: nginx
< Date: Mon, 09 Dec 2013 13:09:00 GMT
< Content-Type: text/html
< Content-Length: 178
< Location: http://www.domain.tld/test/
< Connection: keep-alive
<html>
<head><title>301 Moved Permanently</title></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center>
</body>
</html>
* Connection #0 to host www.domain.tld left intact
* Closing connection #0

user 14:08:55 ~: curl -v http://adminer.domain.tld
* getaddrinfo(3) failed for adminer.domain.tld:80
* Couldn't resolve host 'adminer.domain.tld'
* Closing connection #0
curl: (6) Couldn't resolve host 'adminer.domain.tld'
Subject Author Posted

Subdomains no longer work

Peleke November 23, 2013 12:07PM

Re: Subdomains no longer work

Peleke November 27, 2013 06:38AM

Re: Subdomains no longer work

Francis Daly November 27, 2013 06:12PM

Re: Subdomains no longer work

Peleke December 03, 2013 01:20PM

Re: Subdomains no longer work

Francis Daly December 03, 2013 03:32PM

Re: Subdomains no longer work

Peleke December 09, 2013 08:24AM

Re: Subdomains no longer work

Francis Daly December 09, 2013 12:36PM

Re: Subdomains no longer work

Peleke December 11, 2013 07:21AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 58
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready