Welcome! Log In Create A New Profile

Advanced

Re: why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on?

All files from this thread

File Name File Size   Posted by Date  
smime.p7s 6 KB open | download GreenGecko 01/22/2013 Read message
January 23, 2013 12:10AM
On Jan 23, 2013, at 2:15 , middleforkgis wrote:

> I'm having a difficult time understanding why I'm unable to limit the IP
> address to which nginx binds.
>
> nginx 1.2.6-1
> Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux
>
>
> ================
> root@skokomish:/etc/nginx# netstat -pant |grep nginx
> tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
> 7768/nginx
> tcp 0 0 66.113.100.140:81 0.0.0.0:* LISTEN
> 7768/nginx
>
> shows that it is binding on port 80 of all IP addresses.
> =================
> Yet each of my hosts is explicitly listening on a single IP address:
>
> root@skokomish:/etc/nginx/sites-available# more default
> { listen 127.0.0.1:80; }
> =================
> root@skokomish:/etc/nginx/sites-available# more example
> server
> {
> server_name example.com www.example.com;
> listen 66.113.100.140:80;
> access_log /var/log/ngnix/example.log;
> error_log /var/log/nginx/example.error.log;
>
> location /site {
> alias /data/www/content/site/example;
> }
> location / {
> proxy_pass_header Server;
> proxy_set_header Host $http_host;
> proxy_redirect off;
> proxy_set_header X-Real-IP $remote_addr;
> proxy_set_header X-Scheme $scheme;
> proxy_connect_timeout 10;
> proxy_read_timeout 10;
> proxy_pass http://10.15.20.10:8107/;
> }
> }
>
>
> ==========================
> There is no 'listen' statement in nginx.conf itself:
> root@skokomish:/etc/nginx# grep listen nginx.conf
> # listen localhost:110;
> # listen localhost:143;
> ==========================
> Grepping for 'listen' shows:
>
> root@skokomish:/etc/nginx# for i in `find .`; do grep listen $i;
> done|sort|uniq
> grep: .: Is a directory
> grep: ./sites-enabled: Is a directory
> grep: ./conf.d: Is a directory
> grep: ./sites-available: Is a directory
> { listen 127.0.0.1:80; }
> listen 66.113.100.140:80;
> listen 66.113.100.140:81;
> # listen localhost:110;
> # listen localhost:143;
> root@skokomish:/etc/nginx# ls conf.d
> root@skokomish:/etc/nginx#
>
> ==================================
> Thanks in advance.

If there is server block without a listen directive,
then nginx will listen on *:80.


--
Igor Sysoev
http://nginx.com/support.html

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on?

middleforkgis January 22, 2013 05:15PM

RE: why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on?

Lukas Tribus January 22, 2013 07:28PM

Re: why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on?

middleforkgis January 22, 2013 09:43PM

Re: why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on?

middleforkgis January 22, 2013 09:59PM

Re: why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on? Attachments

GreenGecko January 22, 2013 10:08PM

Re: why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on?

middleforkgis January 22, 2013 11:19PM

Re: why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on?

Igor Sysoev January 23, 2013 12:10AM

SOLVED Re: why is nginx binding to 0.0.0.0:80 when I specify explicit IPs to listen on?

middleforkgis January 23, 2013 11:05AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 233
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready