Welcome! Log In Create A New Profile


Nginx php-fpm setp fastcgi_pass_header not being set

October 18, 2012 09:21AM
I am using Nginx + php-fpm setup

I noticed that I could set fastcgi_param however fastcgi_pass_header is not being set. I tried to print $_SERVER in php which has only fastcgi_params and not fastcgi_pass_headers.

My queries are:
1. Is there any additional configuration parameter needed for fastcgi_pass_headers? I have set 'underscores_in_headers on;', however headers I am trying to set don't have underscores. I tried to manipulate client request headers (through TamperData) it works fine as by default it is on.

2. Is there any other way to check (apart from _SERVER) to check if headers are set properly while passing to php-fpm?

Any help is appreciated.

I have following configuration:

fastcgi_param SERVER_PORT $server_port;
fastcgi_param SERVER_NAME $server_name;

fastcgi_pass_header Authorization;
fastcgi_pass_header Host;

fastcgi_pass_header X-Real-IP;
fastcgi_pass_header X-Forwarded-For;

location block looks like following:

location ~ \.php(.*)$ {
try_files $uri =404;

root /home/myntradomain/public_html;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include /etc/nginx/fastcgi_params;
Subject Author Posted

Nginx php-fpm setp fastcgi_pass_header not being set

hsrmmr October 18, 2012 09:21AM

Re: Nginx php-fpm setp fastcgi_pass_header not being set

VBart October 18, 2012 10:38AM

Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 187
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready