Welcome! Log In Create A New Profile

Advanced

Re: Nginx php-fpm setp fastcgi_pass_header not being set

October 18, 2012 10:38AM
On Thursday 18 October 2012 17:21:58 hsrmmr wrote:
> I am using Nginx + php-fpm setup
>
> I noticed that I could set fastcgi_param however fastcgi_pass_header is
> not being set. I tried to print $_SERVER in php which has only
> fastcgi_params and not fastcgi_pass_headers.
>
> My queries are:
> 1. Is there any additional configuration parameter needed for
> fastcgi_pass_headers? I have set 'underscores_in_headers on;', however
> headers I am trying to set don't have underscores. I tried to manipulate
> client request headers (through TamperData) it works fine as by default it
> is on.
>
> 2. Is there any other way to check (apart from _SERVER) to check if headers
> are set properly while passing to php-fpm?
>
> Any help is appreciated.

It seems that you don't understand what fastcgi_pass_header does.

Please, read the documentation:
http://nginx.org/r/fastcgi_pass_header

wbr, Valentin V. Bartenev

--
http://nginx.com/support.html
http://nginx.org/en/donation.html

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Nginx php-fpm setp fastcgi_pass_header not being set

hsrmmr October 18, 2012 09:21AM

Re: Nginx php-fpm setp fastcgi_pass_header not being set

VBart October 18, 2012 10:38AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 226
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready