Lasse Laursen
March 16, 2012 08:04AM
Try adding:

# Number of hash buckets

server_names_hash_bucket_size 128;

in the 'http' section of your nginx.conf file.

http://wiki.nginx.org/HttpCoreModule#server_names_hash_bucket_size




On 16/03/2012, at 12.57, compiler2k wrote:

> Hi.
>
> I have a Linux Ubuntu 8.04 LTS machine with nginx 0.7.62-0 installed
> from a PPA repository.
>
> NGINX is being working correctly since now, but today I've tried to add
> the 33th "virtualhost" to the sites-available and sites-enabled/
> directory and nginx does not start.
>
> I have 32 working virtualhosts from 000-virthost1 to 031-virthost31,
> but when I try to add 032-virthost (the 33th), nginx refuses to start
> with no error message. If I remove any of the virtualhosts files and add
> the new one (having again a maximum of 32), it works.
>
> Is there a limit on the number of virtualhosts to be served? Maybe it's
> a limit in the number of files or symlinks you can have in
> sites-enabled?
>
> Should I upgrade nginx to correct this behaviour.
>
> Thanks for any help, I don't know how to fix this.
>
> Posted at Nginx Forum: http://forum.nginx.org/read.php?2,223950,223950#msg-223950
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://mailman.nginx.org/mailman/listinfo/nginx

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Can't configure 33 "virtualhosts" in nginx 0.7.62-0 (max=32?)

compiler2k March 16, 2012 07:57AM

Re: Can't configure 33 "virtualhosts" in nginx 0.7.62-0 (max=32?)

Lasse Laursen March 16, 2012 08:04AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 95
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready