Welcome! Log In Create A New Profile

Advanced

Re: Default_server catch all block not working

Maxim Dounin
April 19, 2012 08:38AM
Hello!

On Mon, Apr 16, 2012 at 04:43:46AM -0400, lockev3.0 wrote:

> Well, probably I'm, still novice at Nginx but, that default server block
> is meant to fit when no other block server (server_name) fits. So my
> current problem is that 444 behaviour is arising all thru my nginx
> server, not just that default_server block/vhost
> .....not quit sure If I explained my self better now ? or even
> understood you right ....

I belive Jonathan Matthews is right and the problem is as follows:
your load balancer sees invalid response from your nginx server
(as "return 444" just drops the connection) and starts to think
it's not working (and starts to return errors to clients without
even asking nginx).

There are two possible solutions:

1) Don't use "return 444" but return some correct response. In
any case "return 444" doesn't help at all as long as your nginx is
behind load balancer (as your balancer will return response
anyway).

2) Tune your balancer to ignore such connection closes (not sure
this is possible).

Maxim Dounin

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Default_server catch all block not working

lockev3.0 January 24, 2012 10:26AM

Re: Default_server catch all block not working

António P. P. Almeida January 24, 2012 10:36AM

Re: Default_server catch all block not working

Mit Rowe January 24, 2012 11:52AM

Re: Default_server catch all block not working

lockev3.0 January 24, 2012 12:57PM

Re: Default_server catch all block not working

lockev3.0 February 02, 2012 07:10AM

Re: Default_server catch all block not working

António P. P. Almeida January 24, 2012 02:52PM

Re: Default_server catch all block not working

lockev3.0 January 25, 2012 09:50AM

Re: Default_server catch all block not working

lockev3.0 January 25, 2012 10:39AM

Re: Default_server catch all block not working

lockev3.0 February 01, 2012 06:32AM

Re: Default_server catch all block not working

António P. P. Almeida January 25, 2012 11:18AM

Re: Default_server catch all block not working

lockev3.0 March 22, 2012 12:32PM

Re: Default_server catch all block not working

lockev3.0 March 28, 2012 04:11AM

Re: Default_server catch all block not working

Jonathan Matthews March 28, 2012 12:12PM

Re: Default_server catch all block not working

lockev3.0 April 16, 2012 04:43AM

Re: Default_server catch all block not working

Maxim Dounin April 19, 2012 08:38AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 129
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready