Welcome! Log In Create A New Profile

Advanced

Re: Default_server catch all block not working

António P. P. Almeida
January 24, 2012 10:36AM
On 24 Jan 2012 15h26 WET, nginx-forum@nginx.us wrote:

> Hi, getting quite desperate at the moment about this.
>
> I have a server serving several subdomains; actually proxying'em to
> apache2. So I have main nginx vhost file with all server_name's
> added. Such server names match the defined ServerName's and
> ServerAlias'es of Apache. Beside, I have one more file to define a
> default_server catch all block like follows
>
> server {
> listen 80 default_server;
> server_name _;
> error_log /var/log/nginx/000default-error.log error;
> root /var/www/forvo.com/_templates;
> error_page 404 /404.html;
> location / {
> #return 444;
> return 404;
> }
> location = /404.html {
> internal;
> }
> #rewrite .* http://myfaultysubdomain.com permanent;
> }

AFAICT there's nothing here that should cause the 503s. Do you have
any limits set, be it connection or rate limit?

--- appa





>
> As soon as I enable this file, everything works as expected,
> however, in less than one minute (my site is always being visited),
> all requests (good subdomains and bad subdomains as well) start to
> get 503 response. No log at all seems to change when this happens.
>
> Any clue to what may be happening pleeeeeease ......it's been hours,
> during days, trying to figure out what the h@$!! is going on
>
> Posted at Nginx Forum:
> http://forum.nginx.org/read.php?2,221572,221572#msg-221572
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://mailman.nginx.org/mailman/listinfo/nginx

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Default_server catch all block not working

lockev3.0 January 24, 2012 10:26AM

Re: Default_server catch all block not working

António P. P. Almeida January 24, 2012 10:36AM

Re: Default_server catch all block not working

Mit Rowe January 24, 2012 11:52AM

Re: Default_server catch all block not working

lockev3.0 January 24, 2012 12:57PM

Re: Default_server catch all block not working

lockev3.0 February 02, 2012 07:10AM

Re: Default_server catch all block not working

António P. P. Almeida January 24, 2012 02:52PM

Re: Default_server catch all block not working

lockev3.0 January 25, 2012 09:50AM

Re: Default_server catch all block not working

lockev3.0 January 25, 2012 10:39AM

Re: Default_server catch all block not working

lockev3.0 February 01, 2012 06:32AM

Re: Default_server catch all block not working

António P. P. Almeida January 25, 2012 11:18AM

Re: Default_server catch all block not working

lockev3.0 March 22, 2012 12:32PM

Re: Default_server catch all block not working

lockev3.0 March 28, 2012 04:11AM

Re: Default_server catch all block not working

Jonathan Matthews March 28, 2012 12:12PM

Re: Default_server catch all block not working

lockev3.0 April 16, 2012 04:43AM

Re: Default_server catch all block not working

Maxim Dounin April 19, 2012 08:38AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 92
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready