Welcome! Log In Create A New Profile

Advanced

Re: 400 bad request errors - Firefox and Chrome

Maxim Dounin
September 06, 2011 02:14PM
Hello!

On Tue, Sep 06, 2011 at 01:49:02PM -0400, aries wrote:

> Hello.
> The access.log, have multiples lines similar to:
> [06/Sep/2011:11:05:32 +0500] "-" 400 0 "-" "-" "-"
>
> These are only created when browsing with Firefox or Chrome, do not
> register these errors if you use IExplorer.
> The error only shows in access.log, the page loads properly without
> showing any error.
> I think that it is not a problem of cookies because these errors are
> logged even if disabling the use of cookies on your browser.
> "error_log /var/log/nginx/error.log info;" not show me any data about
> this error.
> I noticed that error is recorded between 3 to 7 seconds after that the
> apache access.log recorded the entry with 200 code for this visit.

With Chrome it's caused by Chrome's behaviour: it opens 2
connections to requested host, and may close one of them without
sending any single request though it (if one connection was
enough). There is no real problem here, just a sign that
connection was opened but not used.

No idea about Firefox, but likely it does something similar.

Maxim Dounin

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

400 bad request errors - Firefox and Chrome

aries September 06, 2011 01:49PM

Re: 400 bad request errors - Firefox and Chrome

Maxim Dounin September 06, 2011 02:14PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 89
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready