Welcome! Log In Create A New Profile

Advanced

400 bad request errors - Firefox and Chrome

September 06, 2011 01:49PM
Hello.
The access.log, have multiples lines similar to:
[06/Sep/2011:11:05:32 +0500] "-" 400 0 "-" "-" "-"

These are only created when browsing with Firefox or Chrome, do not register these errors if you use IExplorer.
The error only shows in access.log, the page loads properly without showing any error.
I think that it is not a problem of cookies because these errors are logged even if disabling the use of cookies on your browser.
"error_log /var/log/nginx/error.log info;" not show me any data about this error.
I noticed that error is recorded between 3 to 7 seconds after that the apache access.log recorded the entry with 200 code for this visit.

I also tried using:
client_header_buffer_size 256k;
large_client_header_buffers 4 256;

As additional data indicate that I'm using:
The Apache keepalive is disabled.

The nginx.conf
user nobody;
worker_processes 1;
error_log /var/log/nginx/error.log info;
worker_rlimit_nofile 20480;
events {
worker_connections 5120; # increase for busier servers
use epoll; # you should use epoll here for Linux kernels 2.6.x
}
http {
server_name_in_redirect off;
server_names_hash_max_size 10240;
server_names_hash_bucket_size 1024;
include mime.types;
default_type application/octet-stream;
server_tokens off;
sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 5;
gzip on;
gzip_vary on;
gzip_disable "MSIE [1-6]\.";
gzip_proxied any;
gzip_http_version 1.1;
gzip_min_length 1000;
gzip_comp_level 6;
gzip_buffers 16 8k;
gzip_types text/plain text/xml text/css application/x-javascript application/xml application/xml+rss text/javascript application/atom+xml;
ignore_invalid_headers on;
client_header_timeout 3m;
client_body_timeout 3m;
send_timeout 3m;
reset_timedout_connection on;
connection_pool_size 256;
client_header_buffer_size 128k;
large_client_header_buffers 8 32k;
client_max_body_size 2M;
client_body_buffer_size 256k;
request_pool_size 4k;
output_buffers 4 32k;
postpone_output 1460;
include "/etc/nginx/vhosts/*";
}

Any suggestions how to fix these errors?.

Thanks.
Subject Author Posted

400 bad request errors - Firefox and Chrome

aries September 06, 2011 01:49PM

Re: 400 bad request errors - Firefox and Chrome

Maxim Dounin September 06, 2011 02:14PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 50
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready