Welcome! Log In Create A New Profile

Advanced

stat() failed

April 15, 2009 11:58PM
Hi,

when I flood my server with ApacheBench, with a concurrency of 1000 I expect most of my queries to be backlogged since I have raised backlog to 8192 by setting nginx listen backlog to that value and also raising the relevant Linux kernel parameters to support this limit.

Now the behavior I actually get is that I will get alot of [i][color=#CC0000]stat() "<some file in a rewrite if>" failed (24: )[/color][/i] in my error log, with the "some file" part actually being a file checked for by a rewrite rule. I get this for pretty much every file that the rewrite rules check for.

Should I change other parameters? My maximum FD (limits.conf) is raised to 65536, as well as the kernel parameter fs.file-max.

Is this a bug with nginx?

I'm running nginx 0.7.50 on Ubuntu Hardy LTS with of 4GB of RAM and Quad Core CPU.

Any help appreciacted.



Edited 2 time(s). Last edit at 04/15/2009 11:59PM by mrouleau.
Subject Author Posted

stat() failed

mrouleau April 15, 2009 11:58PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 330
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready