Did anybody sucessfully compiled Nginx with Modsecurity V3.0 and Modsecurity-Nginx connector recently ?
Since I ma getting below error

checking for ModSecurity library in /usr/local/modsecurity ... not found
./configure: error: ngx_http_modsecurity_module requires the ModSecurity library.
make: *** No rule to make target `build', needed by `default'. Stop.
make: *** No rule to make target `install'. Stop.
make: *** No rule to make target `modules'. Stop.
Is this step correct for nginx configure?

./configure --with-compat --add-dynamic-module="/local/nginxbuild/modsecurity-nginx"
mkuser143 Wrote:
-------------------------------------------------------
> Did anybody sucessfully compiled Nginx with Modsecurity V3.0 and
> Modsecurity-Nginx connector recently ?
> Since I ma getting below error
>
> checking for ModSecurity library in /usr/local/modsecurity ... not
> found
> ./configure: error: ngx_http_modsecurity_module requires the
> ModSecurity library.
> make: *** No rule to make target `build', needed by `default'. Stop.
> make: *** No rule to make target `install'. Stop.
> make: *** No rule to make target `modules'. Stop.



./configure: error: ngx_http_modsecurity_module requires the ModSecurity library.
make: *** No rule to make target `build', needed by `default'. Stop.
make: *** No rule to make target `install'. Stop.
make: *** No rule to make target `modules'. Stop.

Got some new error
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 307
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready