Welcome! Log In Create A New Profile

Advanced

I am new in Nginx, Please help me to convert and setup this .htaccess

Posted by CoolMonu 
I am new in Nginx, Please help me to convert and setup this .htaccess
February 28, 2014 03:35PM
Hello, I'm new in this forum and I really need someone help. Please help me :)

This is .htaccess code:

RewriteEngine On

# Uncomment (remove #) line below if installed in folder and add folder name after /
#Rewritebase /

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f

# Application Handler
RewriteRule ^([_A-Za-z0-9-]+)/?$ index.php?action=$1 [QSA,NC,L]
RewriteRule ^([_A-Za-z0-9-]+)[+]$ index.php?action=stats&id=$1 [QSA,NC,L]

# Admin Panel
RewriteRule ^admin/([_A-Za-z0-9-]+)/?$ admin/index.php?action=$1 [QSA,NC,L]

# Application
RewriteRule ^([_A-Za-z0-9-]+)/([_A-Za-z0-9-]+)/?$ index.php?action=$1&do=$2 [QSA,NC,L]
RewriteRule ^sitemap.xml$ sitemap.php

ErrorDocument 404 /index.php?action=404



I convert it with http://winginx.com/en/htaccess. and result is


# nginx configuration

error_page 404 /index.php?action=404;

location / {
if (!-e $request_filename){
rewrite ^/([_A-Za-z0-9-]+)/?$ /index.php?action=$1 break;
}
rewrite ^/([_A-Za-z0-9-]+)[+]$ /index.php?action=stats&id=$1 break;
rewrite ^/([_A-Za-z0-9-]+)/([_A-Za-z0-9-]+)/?$ /index.php?action=$1&do=$2 break;
}

location /admin {
rewrite ^/admin/([_A-Za-z0-9-]+)/?$ /admin/index.php?action=$1 break;
}

location = /sitemap.xml {
rewrite ^(.*)$ /sitemap.php;
}




But main problem is I can't configure it still now.

This is my /etc/nginx/sites-available/default file. ( I think this is the area where i need to put it)


# You may add here your
# server {
# ...
# }
# statements for each of your virtual hosts to this file

##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# http://wiki.nginx.org/Pitfalls
# http://wiki.nginx.org/QuickStart
# http://wiki.nginx.org/Configuration
#
# Generally, you will want to move this file somewhere, and start with a clean
# file but keep this around for reference. Or just disable in sites-enabled.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

server {
listen 80 default_server;
listen [::]:80 default_server ipv6only=on;

root /usr/share/nginx/html;
index index.php;

# Make site accessible from http://localhost/
server_name localhost;

location / {
# First attempt to serve request as file, then
# as directory, then fall back to displaying a 404.
try_files $uri $uri/ /index.php;
# Uncomment to enable naxsi on this location
# include /etc/nginx/naxsi.rules
}

location /doc/ {
alias /usr/share/doc/;
autoindex on;
allow 127.0.0.1;
allow ::1;
deny all;
}

# Only for nginx-naxsi used with nginx-naxsi-ui : process denied requests
#location /RequestDenied {
# proxy_pass http://127.0.0.1:8080;
#}

#error_page 404 /404.html;

# redirect server error pages to the static page /50x.html
#
#error_page 500 502 503 504 /50x.html;
#location = /50x.html {
# root /usr/share/nginx/html;
#}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
location ~ \.php$ {
fastcgi_split_path_info ^(.+\.php)(/.+)$;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_index index.php;
include fastcgi_params;
}

# deny access to .htaccess files, if Apache's document root
# concurs with nginx's one
#
#location ~ /\.ht {
# deny all;
#}
}


# another virtual host using mix of IP-, name-, and port-based configuration
#
#server {
# listen 8000;
# listen somename:8080;
# server_name somename alias another.alias;
# root html;
# index index.html index.htm;
#
# location / {
# try_files $uri $uri/ =404;
# }
#}


# HTTPS server
#
#server {
# listen 443;
# server_name localhost;
#
# root html;
# index index.html index.htm;
#
# ssl on;
# ssl_certificate cert.pem;
# ssl_certificate_key cert.key;
#
# ssl_session_timeout 5m;
#
# ssl_protocols SSLv3 TLSv1;
# ssl_ciphers ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv3:+EXP;
# ssl_prefer_server_ciphers on;
#
# location / {
# try_files $uri $uri/ =404;
# }
#}




Please someone help me to solve this problem :(
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 92
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready