Welcome! Log In Create A New Profile

Advanced

Moved from Apache, now redirect is broken

Posted by vwyoda 
Moved from Apache, now redirect is broken
February 03, 2013 05:18PM
I am trying to migrate all my sites to NGINX from apache2. One of my sites does a cloaking of the link in a button, which sends them to a page with just a simple redirect.

With Apache2 it just worked, now with NGINX it just hangs on the redirect, but if I type out the full URL path where the redirect file is it works. So seems like NGINX is doing something I am not getting yet.

Here is the code in case this is actually the cause...


index.php - Where the continue button is.. This is only the continue button code.
<div id="continue_button_container">
<a href="<?php echo OFFER_LINK; ?>">
<img alt="continue button" src="<?php echo CONTINUE_BUTTON_SRC;?>" />
</a>
</div>

Here is the actual redirect in the file that it is sending this to.
<?php
require_once "../php/config.php";
header("Location: ".DESTINATION);

In config.php DESTINATION is set to http://google.com .. When its hit, just hangs trying to connect then eventually times out.

Any help is greatly appriciated. If I need to post my configs as well, just let me know which ones and I will gladly post them. Also sorry I can't seem to get [code][/code] tags to work for the post.
Re: Moved from Apache, now redirect is broken
February 03, 2013 07:49PM
Figured it out was because I did not have a / after offer
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 65
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready