Welcome! Log In Create A New Profile

Advanced

Blank PHP pages with Nginx 1.7.4 + PHP 5.6 + Ubuntu 14.04?

Posted by Droidman 
Blank PHP pages with Nginx 1.7.4 + PHP 5.6 + Ubuntu 14.04?
September 10, 2014 05:59AM
Hi,

I'm running Ubuntu 14.04 with nginx 1.7.4 (ppa:nginx/development) and PHP 5.6 (ppa:ondrej/php5-5.6).

Everything was working just fine with nginx 1.7.1 but when I upgraded to 1.7.4 every single PHP page is blank, even phpinfo.

I tried rebuilding my VPS and starting over from scratch but no matter what I did I still get a blank page with 1.7.4.

As soon as I revert to nginx 1.7.1 or the latest build available with the default Ubuntu LTS 14.04 repository there's no problem.

Has anyone else experienced this with 1.7.4-1+trusty? What might be the cause?

Here is the config I'm testing with:

server {
listen 80 default_server;
listen [::]:80 default_server ipv6only=on;

root /var/www/domain.com;
index index.php index.html index.htm;

server_name domain.com;

location / {
try_files $uri $uri/ =404;
}

error_page 404 /404.html;
error_page 500 502 503 504 /50x.html;
location = /50x.html {
root /usr/share/nginx/html;
}

location ~ \.php$ {
try_files $uri =404;
fastcgi_split_path_info ^(.+\.php)(/.+)$;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_index index.php;
include fastcgi_params;
}
}
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 112
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready