Welcome! Log In Create A New Profile

Advanced

Struggling with php-fpm ERRORS

Posted by Adrián Gálvez G. 
Adrián Gálvez G.
Struggling with php-fpm ERRORS
May 02, 2014 02:20PM
There is this issue in the server that is not allowing me to run correctly
php-fpm, but despite this issue everything is running with a problem of 524
CloudFlare time out every time I SEND, POST ,etc

My server Configuration is: 12.04.4 LTS, Precise Pangolin + NGINX + ionCube
+ igBinary + CloudFlare (php-fpm)

Every time I try to start PHP-FPM I get stuck until I open a new session .

PHP-FPM LOG says this :

> [02-May-2014 02:51:05] ERROR: An another FPM instance seems to already
> > listen on /var/run/php5-fpm.sock
> >
> [02-May-2014 02:51:05] ERROR: FPM initialization failed


So far what I've investigate, with my short knowledge is that I have CGI
php.ini, PHP-FPM php.ini CLI php.ini

https://www.dropbox.com/s/nddqpmf0937x739/Screenshot%202014-05-02%2011.19.11.png

that maybe are in conflict

also php-fpm is correctly configured (Well that is what I think):
www.conf:

http://pastebin.com/QcTTBUEW

my NGNIX.conf is just the same that H5BP-NGINX Config provied
and my site-enable is:

server {
> # listen 80 deferred; # for Linux
> # listen 80 accept_filter=httpready; # for FreeBSD
> listen 80;
>
> # The host name to respond to
> server_name censocanino.com www.censocanino.com;
>
> # Path for static files
> root /sites/censocanino.com/public;
>
> # Try static files first, then php
> index index.html index.htm index.php;
>
> # Specific logs for this vhost
> access_log /sites/censocanino.com/log/log-access.log;
> error_log /sites/censocanino.com/log/log-error.log error;
>
> #Specify a charset
> charset utf-8;
>
> # Redirect needed to "hide" index.php
> location / {
> try_files $uri $uri/ /index.php?q=$uri&$args;
> }
>
> # Don't log robots.txt or favicon.ico files
> location ~* ^/(favicon.ico|robots.txt)$ {
> access_log off;
> log_not_found off;
> }
> # Custom 404 page
> error_page 404 /404.php;
>
> location ~*
> ^.+.(gif|jpg|jpeg|png|wmv|avi|mpg|mpeg|mp4|htm|html|js|css|mp3|swf|ico|flv|xml)
> {
> access_log off;
> expires 30d;
> }
>
> # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
> location ~ \.php$ {
> fastcgi_split_path_info ^(.+\.php)(/.+)$;
> # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
>
> # With php5-cgi alone:
> # fastcgi_pass 127.0.0.1:9000;
> # With php5-fpm:
> fastcgi_pass unix:/var/run/php5-fpm.sock;
> fastcgi_intercept_errors on;
> fastcgi_index index.php;
> fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
> include fastcgi_params;
> }
>
> # Deny access to .htaccess
> location ~ /\.ht {
> deny all;
> }
>
> # PHPMYADMIN
> location /phpmyadmin {
> root /usr/share/;
> index index.php index.html index.htm;
> location ~ ^/phpmyadmin/(.+\.php)$ {
> try_files $uri =404;
> root /usr/share/;
> fastcgi_pass unix:/var/run/php5-fpm.sock;
> fastcgi_index index.php;
> fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
> include fastcgi_params;
> }
> location ~*
> ^/phpmyadmin/(.+\.(jpeg|jpg|png|css|gif|ico|js|html|xml|txt))$ {
> root /usr/share/;
> }
> }
> location /phpMyAdmin {
> rewrite ^/* /phpmyadmin last;
> }
>
> # Include the basic h5bp config set
> include h5bp/basic.conf;
> }
>


More reference:

> `http://censocanino.com/phpinfo.php`


thanks


**EDIT**

I just notice that php-fpm.sock is 0kb

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 78
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready