Welcome! Log In Create A New Profile

Advanced

huge quantity of "Listen queue overflow: 193 already in queue awaiting acceptance"

Posted by RedFoxy 
Hi all!
I change server, from an HP with 2 CPU Xeon quad core 8gb ram to a Dell with 2 CPU Xeon quad core and 16gb ram, both servers are with FreeBSD and I'm using same php-fpm and nginx configurations.

But I've a trouble about php-fpm, my log have a really huge of:
sonewconn: pcb 0xfffffe01f2c6f870: Listen queue overflow: 193 already in queue awaiting acceptance

I use PHP 5.3.28 with Suhosin-Patch

that's my php-fpm configuration:

[global]
pid = run/php-fpm.pid

error_log = /var/log/php-fpm/error.log
log_level = error

emergency_restart_threshold = 10
emergency_restart_interval = 1m

process_control_timeout = 10s
process.max = 0

[www]
user = www
group = www
security.limit_extensions = .php

listen = /tmp/php-fpm.$pool.sock
listen.allowed_clients = 127.0.0.1
listen.backlog = -1

pm = static
pm.max_children = 8
pm.max_requests = 10000000

request_slowlog_timeout = 40s
slowlog = /var/log/php-fpm/slow.$pool.log

env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp


Any idea?

--
RedFoxy Darrest
http://www.redfoxy.it


--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
It's not a php-fpm issue, you have to tune up your kernel: http://www.freebsd.org/doc/handbook/configtuning-kernel-limits.html

-----Original Message-----
From: highload-php-en@googlegroups.com [mailto:highload-php-en@googlegroups.com] On Behalf Of RedFoxy
Sent: Thursday, April 17, 2014 11:49 AM
To: highload-php-en@googlegroups.com
Subject: huge quantity of "Listen queue overflow: 193 already in queue awaiting acceptance"

Hi all!
I change server, from an HP with 2 CPU Xeon quad core 8gb ram to a Dell with 2 CPU Xeon quad core and 16gb ram, both servers are with FreeBSD and I'm using same php-fpm and nginx configurations.

But I've a trouble about php-fpm, my log have a really huge of:
sonewconn: pcb 0xfffffe01f2c6f870: Listen queue overflow: 193 already in queue awaiting acceptance

I use PHP 5.3.28 with Suhosin-Patch

that's my php-fpm configuration:

[global]
pid = run/php-fpm.pid

error_log = /var/log/php-fpm/error.log
log_level = error

emergency_restart_threshold = 10
emergency_restart_interval = 1m

process_control_timeout = 10s
process.max = 0

[www]
user = www
group = www
security.limit_extensions = .php

listen = /tmp/php-fpm.$pool.sock
listen.allowed_clients = 127.0.0.1
listen.backlog = -1

pm = static
pm.max_children = 8
pm.max_requests = 10000000

request_slowlog_timeout = 40s
slowlog = /var/log/php-fpm/slow.$pool.log

env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp


Any idea?

--
RedFoxy Darrest
http://www.redfoxy.it


--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 82
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready