Welcome! Log In Create A New Profile

Advanced

Socket Not Being Created

Posted by Ryan 
Ryan
Socket Not Being Created
February 04, 2014 09:34AM
I am running nginx with php5-fpm on Ubuntu. I just noticed one of my
websites isn't working anymore, I was getting a 502 error. After looking at
the nginx error log I could see it was not finding the php-fpm socket, and
I looked at the sockets directory and sure enough it is not there but the
config file is in pool.d to create it.I tried relaoding php5-fpm and even
rebooted the server entirely, nothing worked.

Any ideas?

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Rainer Duffner
Re: Socket Not Being Created
February 04, 2014 09:34AM
Am 02.02.2014 um 21:13 schrieb Ryan <rbilesky@gmail.com>:

> I am running nginx with php5-fpm on Ubuntu. I just noticed one of my websites isn't working anymore, I was getting a 502 error. After looking at the nginx error log I could see it was not finding the php-fpm socket, and I looked at the sockets directory and sure enough it is not there but the config file is in pool.d to create it.I tried relaoding php5-fpm and even rebooted the server entirely, nothing worked.
>
> Any ideas?




Can you show the php-fpm config files?

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Vid Luther
Re: Socket Not Being Created
February 04, 2014 09:34AM
Are you sure that the files in pool.d/* are being loaded? To make sure they
are try this

In your config file for the pool that doesn't seem to be working, enter
some random characters that would cause a syntax error, then try php5-fpm
-t , if it passes, then you know the config file is not being loaded.


On Sunday, February 2, 2014 2:13:03 PM UTC-6, Ryan wrote:
>
> I am running nginx with php5-fpm on Ubuntu. I just noticed one of my
> websites isn't working anymore, I was getting a 502 error. After looking at
> the nginx error log I could see it was not finding the php-fpm socket, and
> I looked at the sockets directory and sure enough it is not there but the
> config file is in pool.d to create it.I tried relaoding php5-fpm and even
> rebooted the server entirely, nothing worked.
>
> Any ideas?
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 45
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready