file not found.....
November 07, 2013 05:27PM

I installed a joomla on a httpd in /var/www/html and that worked well. I tried to switch to nginx / php-fpm.
When I try I've a nginx standard page. When I try the I get the "No input file specified." message.

In the nginx logs, I get following:
2013/11/07 23:11:12 [error] 29996#0: *58 FastCGI sent in stderr: "Unable to open primary script: /var/www/html/index.php (No such file or directory)" while reading response header from upstream, client:, server:, request: "GET / HTTP/1.1", upstream: "fastcgi://", host: "".

I've nothing in the php-fpm logs. The path that generated is good. Php is ran with apache user that has r/x rights on all file hierarchy. Nginx user has also same rights.

Some people of Nginx irc said me that was a "php" problem, but since I've no message and I don't no well any of theses systems, I do not find solution on the net.

Can you help me please ?

What information do you need to better help me ?

Thanks a lot.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 165
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready