Welcome! Log In Create A New Profile

Advanced

accelerated upload

Posted by nhadie ramos 
nhadie ramos
accelerated upload
August 15, 2013 12:06PM
Hi All,

I am doing some comparison to test if accelerated support is really better,
so i am testing:

nginx+php-fpm *with* accelerated support
nginx+php-fpm *without* accelerated support
nginx_php-cgi only

uploading a 350MB file. and using this config:

location ~ \.php$ {
include fastcgi_params;

client_body_temp_path /temp;
fastcgi_pass_request_body off;
client_body_in_file_only on;
fastcgi_param REQUEST_BODY_FILE $request_body_file;

#use php-cgi
#fastcgi_pass 127.0.0.1:10005;

#use php-fpm
fastcgi_pass 127.0.0.1:9000;

fastcgi_index $dir_index;
fastcgi_param DOCUMENT_ROOT $doc_root;
fastcgi_split_path_info ^(.+?\.php)(/.*)$;
fastcgi_param SCRIPT_FILENAME
$document_root$fastcgi_script_name;
}

but am i missing something on PHP side or config side as it seems i am
getting the same response time using php-fpm without the accelerated
support settings
and also using php-cgi, response time is the same for all scenarios.


with accelerated support using php-fpm:
10.254.12.84 - - [15/Aug/2013:10:26:05 +0800] "POST /curlupload.php
HTTP/1.1" 200 359 "-" "-" "-" 33.404 1.342 .
10.254.12.84 - - [15/Aug/2013:10:26:51 +0800] "POST /curlupload.php
HTTP/1.1" 200 359 "-" "-" "-" 32.168 1.216 .

without accelerated support using php-fpm:
10.254.12.84 - - [15/Aug/2013:11:02:58 +0800] "POST /curlupload.php
HTTP/1.1" 200 359 "-" "-" "-" 32.182 1.229 .
10.254.12.84 - - [15/Aug/2013:11:03:32 +0800] "POST /curlupload.php
HTTP/1.1" 200 359 "-" "-" "-" 33.218 1.208 .

using php-cgi
10.254.12.84 - - [15/Aug/2013:11:48:57 +0800] "POST /curlupload.php
HTTP/1.1" 200 359 "-" "-" "-" 32.371 1.418 .
10.254.12.84 - - [15/Aug/2013:11:49:30 +0800] "POST /curlupload.php
HTTP/1.1" 200 359 "-" "-" "-" 33.093 1.308 .

TIA

Regards,
Ron

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Re: accelerated upload
August 15, 2013 01:26PM
When I was putting the request body into a variable I was having issues... I want to say we ran out of memory.

Now we use plupload and try to have the client chunk the data, you get upload progress, and not one long transaction that can fail like typical standard file upload.



On Aug 15, 2013, at 9:00 AM, nhadie ramos <nhadie@gmail.com> wrote:

> Hi All,
>
> I am doing some comparison to test if accelerated support is really better, so i am testing:
>
> nginx+php-fpm *with* accelerated support
> nginx+php-fpm *without* accelerated support
> nginx_php-cgi only
>
> uploading a 350MB file. and using this config:
>
> location ~ \.php$ {
> include fastcgi_params;
>
> client_body_temp_path /temp;
> fastcgi_pass_request_body off;
> client_body_in_file_only on;
> fastcgi_param REQUEST_BODY_FILE $request_body_file;
>
> #use php-cgi
> #fastcgi_pass 127.0.0.1:10005;
>
> #use php-fpm
> fastcgi_pass 127.0.0.1:9000;
>
> fastcgi_index $dir_index;
> fastcgi_param DOCUMENT_ROOT $doc_root;
> fastcgi_split_path_info ^(.+?\.php)(/.*)$;
> fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
> }
>
> but am i missing something on PHP side or config side as it seems i am getting the same response time using php-fpm without the accelerated support settings
> and also using php-cgi, response time is the same for all scenarios.
>
>
> with accelerated support using php-fpm:
> 10.254.12.84 - - [15/Aug/2013:10:26:05 +0800] "POST /curlupload.php HTTP/1.1" 200 359 "-" "-" "-" 33.404 1.342 .
> 10.254.12.84 - - [15/Aug/2013:10:26:51 +0800] "POST /curlupload.php HTTP/1.1" 200 359 "-" "-" "-" 32.168 1.216 .
>
> without accelerated support using php-fpm:
> 10.254.12.84 - - [15/Aug/2013:11:02:58 +0800] "POST /curlupload.php HTTP/1.1" 200 359 "-" "-" "-" 32.182 1.229 .
> 10.254.12.84 - - [15/Aug/2013:11:03:32 +0800] "POST /curlupload.php HTTP/1.1" 200 359 "-" "-" "-" 33.218 1.208 .
>
> using php-cgi
> 10.254.12.84 - - [15/Aug/2013:11:48:57 +0800] "POST /curlupload.php HTTP/1.1" 200 359 "-" "-" "-" 32.371 1.418 .
> 10.254.12.84 - - [15/Aug/2013:11:49:30 +0800] "POST /curlupload.php HTTP/1.1" 200 359 "-" "-" "-" 33.093 1.308 .
>
> TIA
>
> Regards,
> Ron
> --
>
> ---
> You received this message because you are subscribed to the Google Groups "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
nhadie ramos
Re: accelerated upload
August 18, 2013 07:50PM
Hi Mike,

Thank you for the info, i was not really having issues on failing
transaction. i wanted to make a comparison between those 3 setup so i know
which one is better.
accelerated support is supposedly better but i don't see any difference on
the response time. Is there anything i am missing on setting up the
accelerated support? TIA.

Regards,
Ron


On Friday, 16 August 2013 01:24:33 UTC+8, mike503 wrote:
>
> When I was putting the request body into a variable I was having issues...
> I want to say we ran out of memory.
>
> Now we use plupload and try to have the client chunk the data, you get
> upload progress, and not one long transaction that can fail like typical
> standard file upload.
>
>
>
> On Aug 15, 2013, at 9:00 AM, nhadie ramos <nha...@gmail.com <javascript:>>
> wrote:
>
> Hi All,
>
> I am doing some comparison to test if accelerated support is really
> better, so i am testing:
>
> nginx+php-fpm *with* accelerated support
> nginx+php-fpm *without* accelerated support
> nginx_php-cgi only
>
> uploading a 350MB file. and using this config:
>
> location ~ \.php$ {
> include fastcgi_params;
>
> client_body_temp_path /temp;
> fastcgi_pass_request_body off;
> client_body_in_file_only on;
> fastcgi_param REQUEST_BODY_FILE $request_body_file;
>
> #use php-cgi
> #fastcgi_pass 127.0.0.1:10005;
>
> #use php-fpm
> fastcgi_pass 127.0.0.1:9000;
>
> fastcgi_index $dir_index;
> fastcgi_param DOCUMENT_ROOT $doc_root;
> fastcgi_split_path_info ^(.+?\.php)(/.*)$;
> fastcgi_param SCRIPT_FILENAME
> $document_root$fastcgi_script_name;
> }
>
> but am i missing something on PHP side or config side as it seems i am
> getting the same response time using php-fpm without the accelerated
> support settings
> and also using php-cgi, response time is the same for all scenarios.
>
>
> with accelerated support using php-fpm:
> 10.254.12.84 - - [15/Aug/2013:10:26:05 +0800] "POST /curlupload.php
> HTTP/1.1" 200 359 "-" "-" "-" 33.404 1.342 .
> 10.254.12.84 - - [15/Aug/2013:10:26:51 +0800] "POST /curlupload.php
> HTTP/1.1" 200 359 "-" "-" "-" 32.168 1.216 .
>
> without accelerated support using php-fpm:
> 10.254.12.84 - - [15/Aug/2013:11:02:58 +0800] "POST /curlupload.php
> HTTP/1.1" 200 359 "-" "-" "-" 32.182 1.229 .
> 10.254.12.84 - - [15/Aug/2013:11:03:32 +0800] "POST /curlupload.php
> HTTP/1.1" 200 359 "-" "-" "-" 33.218 1.208 .
>
> using php-cgi
> 10.254.12.84 - - [15/Aug/2013:11:48:57 +0800] "POST /curlupload.php
> HTTP/1.1" 200 359 "-" "-" "-" 32.371 1.418 .
> 10.254.12.84 - - [15/Aug/2013:11:49:30 +0800] "POST /curlupload.php
> HTTP/1.1" 200 359 "-" "-" "-" 33.093 1.308 .
>
> TIA
>
> Regards,
> Ron
>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-...@googlegroups.com <javascript:>.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 60
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready