Welcome! Log In Create A New Profile

Advanced

PHP Fatal error with nginx

Posted by pablo.rodriguez 
PHP Fatal error with nginx
August 04, 2013 03:28AM
Hello!

I'm having, in a PHP form, when I'm submiting one email, the next error in
error.log:

2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr: "PHP
message: PHP Warning:
require_once(TEMPLATEPATH/functions/theme-functions.php): failed to open
stream: No such file or directory in
/web/domain.com/public/wp-content/themes/launcheffect/functions.php on line
151

PHP message: PHP Fatal error: require_once(): Failed opening required
'TEMPLATEPATH/functions/theme-functions.php'
(include_path='.:/usr/share/php:/usr/share/pear') in
/web/domain.com/public/wp-content/themes/launcheffect/functions.php on line
151" while reading response header from upstream, client: 71.28.74.212,
server: www.domain.com, request: "POST
/wp-content/themes/launcheffect/post.php HTTP/1.1", upstream:
"fastcgi://127.0.0.1:9000", host: "www.domain.com", referrer:
"http://www.domain.com/"

I've been reading about permissions, about nginx and fastcgi, about PHPfpm,
reviewing my config...without success.

Of course I've that file/directory.

Can anyone help me to solve this error?

Thanks in advance!

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Przemysław Pawliczuk
Re: PHP Fatal error with nginx
August 04, 2013 09:00AM
Are you using a chrooted env?
On Aug 4, 2013 9:26 AM, "Pablo Rodríguez" <info@pablorodriguezgonzalez.es>
wrote:

> Hello!
>
> I'm having, in a PHP form, when I'm submiting one email, the next error in
> error.log:
>
> 2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr: "PHP
> message: PHP Warning:
> require_once(TEMPLATEPATH/functions/theme-functions.php): failed to open
> stream: No such file or directory in /web/
> domain.com/public/wp-content/themes/launcheffect/functions.php on line 151
>
> PHP message: PHP Fatal error: require_once(): Failed opening required
> 'TEMPLATEPATH/functions/theme-functions.php'
> (include_path='.:/usr/share/php:/usr/share/pear') in /web/
> domain.com/public/wp-content/themes/launcheffect/functions.php on line
> 151" while reading response header from upstream, client: 71.28.74.212,
> server: www.domain.com, request: "POST
> /wp-content/themes/launcheffect/post.php HTTP/1.1", upstream: "fastcgi://
> 127.0.0.1:9000", host: "www.domain.com", referrer: "http://www.domain.com/
> "
>
> I've been reading about permissions, about nginx and fastcgi, about
> PHPfpm, reviewing my config...without success.
>
> Of course I've that file/directory.
>
> Can anyone help me to solve this error?
>
> Thanks in advance!
>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Re: PHP Fatal error with nginx
August 04, 2013 09:06AM
Thanks for your reply!

Not, I'm not using a chrootred environment.

Best.


On 4 August 2013 14:59, Przemysław Pawliczuk <p.pawliczuk@gmail.com> wrote:

> Are you using a chrooted env?
> On Aug 4, 2013 9:26 AM, "Pablo Rodríguez" <info@pablorodriguezgonzalez.es>
> wrote:
>
>> Hello!
>>
>> I'm having, in a PHP form, when I'm submiting one email, the next error
>> in error.log:
>>
>> 2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr: "PHP
>> message: PHP Warning:
>> require_once(TEMPLATEPATH/functions/theme-functions.php): failed to open
>> stream: No such file or directory in /web/
>> domain.com/public/wp-content/themes/launcheffect/functions.php on line
>> 151
>>
>> PHP message: PHP Fatal error: require_once(): Failed opening required
>> 'TEMPLATEPATH/functions/theme-functions.php'
>> (include_path='.:/usr/share/php:/usr/share/pear') in /web/
>> domain.com/public/wp-content/themes/launcheffect/functions.php on line
>> 151" while reading response header from upstream, client: 71.28.74.212,
>> server: www.domain.com, request: "POST
>> /wp-content/themes/launcheffect/post.php HTTP/1.1", upstream: "fastcgi://
>> 127.0.0.1:9000", host: "www.domain.com", referrer: "
>> http://www.domain.com/"
>>
>> I've been reading about permissions, about nginx and fastcgi, about
>> PHPfpm, reviewing my config...without success.
>>
>> Of course I've that file/directory.
>>
>> Can anyone help me to solve this error?
>>
>> Thanks in advance!
>>
>> --
>>
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "highload-php-en" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to highload-php-en+unsubscribe@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>>
>>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Przemysław Pawliczuk
Re: PHP Fatal error with nginx
August 04, 2013 03:48PM
Use ktrace/strace to verify, which OS' error is being produced. It's the
most straight way to find out what's going on with paths or permissions.


2013/8/4 Pablo Rodríguez González <info@pablorodriguezgonzalez.es>

> Thanks for your reply!
>
> Not, I'm not using a chrootred environment.
>
> Best.
>
>
> On 4 August 2013 14:59, Przemysław Pawliczuk <p.pawliczuk@gmail.com>wrote:
>
>> Are you using a chrooted env?
>> On Aug 4, 2013 9:26 AM, "Pablo Rodríguez" <info@pablorodriguezgonzalez.es>
>> wrote:
>>
>>> Hello!
>>>
>>> I'm having, in a PHP form, when I'm submiting one email, the next error
>>> in error.log:
>>>
>>> 2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr: "PHP
>>> message: PHP Warning:
>>> require_once(TEMPLATEPATH/functions/theme-functions.php): failed to open
>>> stream: No such file or directory in /web/
>>> domain.com/public/wp-content/themes/launcheffect/functions.php on line
>>> 151
>>>
>>> PHP message: PHP Fatal error: require_once(): Failed opening required
>>> 'TEMPLATEPATH/functions/theme-functions.php'
>>> (include_path='.:/usr/share/php:/usr/share/pear') in /web/
>>> domain.com/public/wp-content/themes/launcheffect/functions.php on line
>>> 151" while reading response header from upstream, client: 71.28.74.212,
>>> server: www.domain.com, request: "POST
>>> /wp-content/themes/launcheffect/post.php HTTP/1.1", upstream: "fastcgi://
>>> 127.0.0.1:9000", host: "www.domain.com", referrer: "
>>> http://www.domain.com/"
>>>
>>> I've been reading about permissions, about nginx and fastcgi, about
>>> PHPfpm, reviewing my config...without success.
>>>
>>> Of course I've that file/directory.
>>>
>>> Can anyone help me to solve this error?
>>>
>>> Thanks in advance!
>>>
>>> --
>>>
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "highload-php-en" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to highload-php-en+unsubscribe@googlegroups.com.
>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>
>>>
>>>
>> --
>>
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "highload-php-en" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to highload-php-en+unsubscribe@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>>
>>
>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Re: PHP Fatal error with nginx
August 04, 2013 03:56PM
Thanks!

I haven't clear how to use it, because I suppose that I need to strace the
pid from php5-fpm, see the next:

21897 www-data 20 0 448m 105m 37m S 0.0 17.9 0:21.48
php5-fpm

21474 www-data 20 0 442m 99m 36m S 0.0 16.8 1:17.74
php5-fpm

21477 www-data 20 0 439m 96m 37m S 0.0 16.4 1:15.46 php5-fpm

But when I do that I've nothing:

root@socrates:/home/ubuntu# strace -p 21897
Process 21897 attached - interrupt to quit

Any help would be appreciated.

Best.

El domingo, 4 de agosto de 2013 21:46:01 UTC+2, eRIZ escribió:
>
> Use ktrace/strace to verify, which OS' error is being produced. It's the
> most straight way to find out what's going on with paths or permissions.
>
>
> 2013/8/4 Pablo Rodríguez González <in...@pablorodriguezgonzalez..es<javascript:>
> >
>
>> Thanks for your reply!
>>
>> Not, I'm not using a chrootred environment.
>>
>> Best.
>>
>>
>> On 4 August 2013 14:59, Przemysław Pawliczuk <p.paw...@gmail.com<javascript:>
>> > wrote:
>>
>>> Are you using a chrooted env?
>>> On Aug 4, 2013 9:26 AM, "Pablo Rodríguez" <
>>> in...@pablorodriguezgonzalez.es <javascript:>> wrote:
>>>
>>>> Hello!
>>>>
>>>> I'm having, in a PHP form, when I'm submiting one email, the next error
>>>> in error.log:
>>>>
>>>> 2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr: "PHP
>>>> message: PHP Warning:
>>>> require_once(TEMPLATEPATH/functions/theme-functions.php): failed to open
>>>> stream: No such file or directory in /web/
>>>> domain.com/public/wp-content/themes/launcheffect/functions.php on line
>>>> 151
>>>>
>>>> PHP message: PHP Fatal error: require_once(): Failed opening required
>>>> 'TEMPLATEPATH/functions/theme-functions.php'
>>>> (include_path='.:/usr/share/php:/usr/share/pear') in /web/
>>>> domain.com/public/wp-content/themes/launcheffect/functions.php on line
>>>> 151" while reading response header from upstream, client: 71.28.74.212,
>>>> server: www.domain.com, request: "POST
>>>> /wp-content/themes/launcheffect/post.php HTTP/1.1", upstream: "fastcgi://
>>>> 127.0.0.1:9000", host: "www.domain.com", referrer: "
>>>> http://www.domain.com/"
>>>>
>>>> I've been reading about permissions, about nginx and fastcgi, about
>>>> PHPfpm, reviewing my config...without success.
>>>>
>>>> Of course I've that file/directory.
>>>>
>>>> Can anyone help me to solve this error?
>>>>
>>>> Thanks in advance!
>>>>
>>>> --
>>>>
>>>> ---
>>>> You received this message because you are subscribed to the Google
>>>> Groups "highload-php-en" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>> an email to highload-php-...@googlegroups.com <javascript:>.
>>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>>
>>>>
>>>>
>>> --
>>>
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "highload-php-en" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to highload-php-...@googlegroups.com <javascript:>.
>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>
>>>
>>>
>>
>> --
>>
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "highload-php-en" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to highload-php-...@googlegroups.com <javascript:>.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>>
>>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Przemysław Pawliczuk
Re: PHP Fatal error with nginx
August 05, 2013 06:42AM
Use the output file param, then make request and kill the pool. After that
open some kind of binary viewer and look for whole paths the worker is
trying to open. There will be some I/O errors if they occur.

AFAIR:
ktrace -p PID -o output_file
On Aug 4, 2013 9:55 PM, "Pablo Rodríguez" <info@pablorodriguezgonzalez..es>
wrote:

> Thanks!
>
> I haven't clear how to use it, because I suppose that I need to strace the
> pid from php5-fpm, see the next:
>
> 21897 www-data 20 0 448m 105m 37m S 0.0 17.9 0:21.48
> php5-fpm
>
> 21474 www-data 20 0 442m 99m 36m S 0.0 16.8 1:17.74
> php5-fpm
>
> 21477 www-data 20 0 439m 96m 37m S 0.0 16.4 1:15.46 php5-fpm
>
> But when I do that I've nothing:
>
> root@socrates:/home/ubuntu# strace -p 21897
> Process 21897 attached - interrupt to quit
>
> Any help would be appreciated.
>
> Best.
>
> El domingo, 4 de agosto de 2013 21:46:01 UTC+2, eRIZ escribió:
>>
>> Use ktrace/strace to verify, which OS' error is being produced. It's the
>> most straight way to find out what's going on with paths or permissions.
>>
>>
>> 2013/8/4 Pablo Rodríguez González <in...@pablorodriguezgonzalez.**es>
>>
>>> Thanks for your reply!
>>>
>>> Not, I'm not using a chrootred environment.
>>>
>>> Best.
>>>
>>>
>>> On 4 August 2013 14:59, Przemysław Pawliczuk <p.paw...@gmail.com> wrote:
>>>
>>>> Are you using a chrooted env?
>>>> On Aug 4, 2013 9:26 AM, "Pablo Rodríguez" <
>>>> in...@pablorodriguezgonzalez.**es> wrote:
>>>>
>>>>> Hello!
>>>>>
>>>>> I'm having, in a PHP form, when I'm submiting one email, the next
>>>>> error in error.log:
>>>>>
>>>>> 2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr: "PHP
>>>>> message: PHP Warning: require_once(TEMPLATEPATH/**
>>>>> functions/theme-functions.php)**: failed to open stream: No such file
>>>>> or directory in /web/domain.com/public/wp-**
>>>>> content/themes/launcheffect/**functions.phphttp://domain.com/public/wp-content/themes/launcheffect/functions.phpon line 151
>>>>>
>>>>> PHP message: PHP Fatal error: require_once(): Failed opening required
>>>>> 'TEMPLATEPATH/functions/theme-**functions.php'
>>>>> (include_path='.:/usr/share/**php:/usr/share/pear') in /web/
>>>>> domain.com/public/wp-**content/themes/launcheffect/**functions.phphttp://domain.com/public/wp-content/themes/launcheffect/functions.phpon line 151" while reading response header from upstream, client:
>>>>> 71.28.74.212, server: www.domain.com, request: "POST
>>>>> /wp-content/themes/**launcheffect/post.php HTTP/1.1", upstream:
>>>>> "fastcgi://127.0.0.1:9000", host: "www.domain.com", referrer: "
>>>>> http://www.domain.com/"
>>>>>
>>>>> I've been reading about permissions, about nginx and fastcgi, about
>>>>> PHPfpm, reviewing my config...without success.
>>>>>
>>>>> Of course I've that file/directory.
>>>>>
>>>>> Can anyone help me to solve this error?
>>>>>
>>>>> Thanks in advance!
>>>>>
>>>>> --
>>>>>
>>>>> ---
>>>>> You received this message because you are subscribed to the Google
>>>>> Groups "highload-php-en" group.
>>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>>> an email to highload-php-...@**googlegroups.com.
>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>> .
>>>>>
>>>>>
>>>>>
>>>> --
>>>>
>>>> ---
>>>> You received this message because you are subscribed to the Google
>>>> Groups "highload-php-en" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>> an email to highload-php-...@**googlegroups.com.
>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>> .
>>>>
>>>>
>>>>
>>>
>>> --
>>>
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "highload-php-en" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to highload-php-...@**googlegroups.com.
>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>> .
>>>
>>>
>>>
>>
>> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Re: PHP Fatal error with nginx
August 05, 2013 09:26AM
Thanks again!

I can't see nothing special.

Anyway, I've solved right now disabling a Wordpress plugin, incredible :(

Best.


On 5 August 2013 12:40, Przemysław Pawliczuk <p.pawliczuk@gmail.com> wrote:

> Use the output file param, then make request and kill the pool. After that
> open some kind of binary viewer and look for whole paths the worker is
> trying to open. There will be some I/O errors if they occur.
>
> AFAIR:
> ktrace -p PID -o output_file
> On Aug 4, 2013 9:55 PM, "Pablo Rodríguez" <info@pablorodriguezgonzalez.es>
> wrote:
>
>> Thanks!
>>
>> I haven't clear how to use it, because I suppose that I need to strace
>> the pid from php5-fpm, see the next:
>>
>> 21897 www-data 20 0 448m 105m 37m S 0.0 17.9 0:21.48
>> php5-fpm
>>
>> 21474 www-data 20 0 442m 99m 36m S 0.0 16.8 1:17.74
>> php5-fpm
>>
>> 21477 www-data 20 0 439m 96m 37m S 0.0 16.4 1:15.46 php5-fpm
>>
>> But when I do that I've nothing:
>>
>> root@socrates:/home/ubuntu# strace -p 21897
>> Process 21897 attached - interrupt to quit
>>
>> Any help would be appreciated.
>>
>> Best.
>>
>> El domingo, 4 de agosto de 2013 21:46:01 UTC+2, eRIZ escribió:
>>>
>>> Use ktrace/strace to verify, which OS' error is being produced. It's the
>>> most straight way to find out what's going on with paths or permissions..
>>>
>>>
>>> 2013/8/4 Pablo Rodríguez González <in...@pablorodriguezgonzalez.**es>
>>>
>>>> Thanks for your reply!
>>>>
>>>> Not, I'm not using a chrootred environment.
>>>>
>>>> Best.
>>>>
>>>>
>>>> On 4 August 2013 14:59, Przemysław Pawliczuk <p.paw...@gmail.com>wrote:
>>>>
>>>>> Are you using a chrooted env?
>>>>> On Aug 4, 2013 9:26 AM, "Pablo Rodríguez" <
>>>>> in...@pablorodriguezgonzalez.**es> wrote:
>>>>>
>>>>>> Hello!
>>>>>>
>>>>>> I'm having, in a PHP form, when I'm submiting one email, the next
>>>>>> error in error.log:
>>>>>>
>>>>>> 2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr: "PHP
>>>>>> message: PHP Warning: require_once(TEMPLATEPATH/**
>>>>>> functions/theme-functions.php)**: failed to open stream: No such
>>>>>> file or directory in /web/domain.com/public/wp-**
>>>>>> content/themes/launcheffect/**functions.phphttp://domain.com/public/wp-content/themes/launcheffect/functions.phpon line 151
>>>>>>
>>>>>> PHP message: PHP Fatal error: require_once(): Failed opening required
>>>>>> 'TEMPLATEPATH/functions/theme-**functions.php'
>>>>>> (include_path='.:/usr/share/**php:/usr/share/pear') in /web/
>>>>>> domain.com/public/wp-**content/themes/launcheffect/**functions.phphttp://domain.com/public/wp-content/themes/launcheffect/functions.phpon line 151" while reading response header from upstream, client:
>>>>>> 71.28.74.212, server: www.domain.com, request: "POST
>>>>>> /wp-content/themes/**launcheffect/post.php HTTP/1.1", upstream:
>>>>>> "fastcgi://127.0.0.1:9000", host: "www.domain.com", referrer: "
>>>>>> http://www.domain.com/"
>>>>>>
>>>>>> I've been reading about permissions, about nginx and fastcgi, about
>>>>>> PHPfpm, reviewing my config...without success.
>>>>>>
>>>>>> Of course I've that file/directory.
>>>>>>
>>>>>> Can anyone help me to solve this error?
>>>>>>
>>>>>> Thanks in advance!
>>>>>>
>>>>>> --
>>>>>>
>>>>>> ---
>>>>>> You received this message because you are subscribed to the Google
>>>>>> Groups "highload-php-en" group.
>>>>>> To unsubscribe from this group and stop receiving emails from it,
>>>>>> send an email to highload-php-...@**googlegroups.com.
>>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>>> .
>>>>>>
>>>>>>
>>>>>>
>>>>> --
>>>>>
>>>>> ---
>>>>> You received this message because you are subscribed to the Google
>>>>> Groups "highload-php-en" group.
>>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>>> an email to highload-php-...@**googlegroups.com.
>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>> .
>>>>>
>>>>>
>>>>>
>>>>
>>>> --
>>>>
>>>> ---
>>>> You received this message because you are subscribed to the Google
>>>> Groups "highload-php-en" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>> an email to highload-php-...@**googlegroups.com.
>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>> .
>>>>
>>>>
>>>>
>>>
>>> --
>>
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "highload-php-en" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to highload-php-en+unsubscribe@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>>
>>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Przemysław Pawliczuk
Re: PHP Fatal error with nginx
August 05, 2013 01:54PM
Which one it was?
On Aug 5, 2013 3:24 PM, "Pablo Rodríguez González" <
info@pablorodriguezgonzalez.es> wrote:

> Thanks again!
>
> I can't see nothing special.
>
> Anyway, I've solved right now disabling a Wordpress plugin, incredible :(
>
> Best.
>
>
> On 5 August 2013 12:40, Przemysław Pawliczuk <p.pawliczuk@gmail.com>wrote:
>
>> Use the output file param, then make request and kill the pool. After
>> that open some kind of binary viewer and look for whole paths the worker is
>> trying to open. There will be some I/O errors if they occur.
>>
>> AFAIR:
>> ktrace -p PID -o output_file
>> On Aug 4, 2013 9:55 PM, "Pablo Rodríguez" <info@pablorodriguezgonzalez.es>
>> wrote:
>>
>>> Thanks!
>>>
>>> I haven't clear how to use it, because I suppose that I need to strace
>>> the pid from php5-fpm, see the next:
>>>
>>> 21897 www-data 20 0 448m 105m 37m S 0.0 17.9 0:21.48
>>> php5-fpm
>>>
>>> 21474 www-data 20 0 442m 99m 36m S 0.0 16.8 1:17.74
>>> php5-fpm
>>>
>>> 21477 www-data 20 0 439m 96m 37m S 0.0 16.4 1:15.46 php5-fpm
>>>
>>> But when I do that I've nothing:
>>>
>>> root@socrates:/home/ubuntu# strace -p 21897
>>> Process 21897 attached - interrupt to quit
>>>
>>> Any help would be appreciated.
>>>
>>> Best.
>>>
>>> El domingo, 4 de agosto de 2013 21:46:01 UTC+2, eRIZ escribió:
>>>>
>>>> Use ktrace/strace to verify, which OS' error is being produced. It's
>>>> the most straight way to find out what's going on with paths or permissions.
>>>>
>>>>
>>>> 2013/8/4 Pablo Rodríguez González <in...@pablorodriguezgonzalez.**es>
>>>>
>>>>> Thanks for your reply!
>>>>>
>>>>> Not, I'm not using a chrootred environment.
>>>>>
>>>>> Best.
>>>>>
>>>>>
>>>>> On 4 August 2013 14:59, Przemysław Pawliczuk <p.paw...@gmail.com>wrote:
>>>>>
>>>>>> Are you using a chrooted env?
>>>>>> On Aug 4, 2013 9:26 AM, "Pablo Rodríguez" <
>>>>>> in...@pablorodriguezgonzalez.**es> wrote:
>>>>>>
>>>>>>> Hello!
>>>>>>>
>>>>>>> I'm having, in a PHP form, when I'm submiting one email, the next
>>>>>>> error in error.log:
>>>>>>>
>>>>>>> 2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr:
>>>>>>> "PHP message: PHP Warning: require_once(TEMPLATEPATH/**
>>>>>>> functions/theme-functions.php)**: failed to open stream: No such
>>>>>>> file or directory in /web/domain.com/public/wp-**
>>>>>>> content/themes/launcheffect/**functions.phphttp://domain.com/public/wp-content/themes/launcheffect/functions.phpon line 151
>>>>>>>
>>>>>>> PHP message: PHP Fatal error: require_once(): Failed opening
>>>>>>> required 'TEMPLATEPATH/functions/theme-**functions.php'
>>>>>>> (include_path='.:/usr/share/**php:/usr/share/pear') in /web/
>>>>>>> domain.com/public/wp-**content/themes/launcheffect/**functions.phphttp://domain.com/public/wp-content/themes/launcheffect/functions.phpon line 151" while reading response header from upstream, client:
>>>>>>> 71.28.74.212, server: www.domain.com, request: "POST
>>>>>>> /wp-content/themes/**launcheffect/post.php HTTP/1.1", upstream:
>>>>>>> "fastcgi://127.0.0.1:9000", host: "www.domain.com", referrer: "
>>>>>>> http://www.domain.com/"
>>>>>>>
>>>>>>> I've been reading about permissions, about nginx and fastcgi, about
>>>>>>> PHPfpm, reviewing my config...without success.
>>>>>>>
>>>>>>> Of course I've that file/directory.
>>>>>>>
>>>>>>> Can anyone help me to solve this error?
>>>>>>>
>>>>>>> Thanks in advance!
>>>>>>>
>>>>>>> --
>>>>>>>
>>>>>>> ---
>>>>>>> You received this message because you are subscribed to the Google
>>>>>>> Groups "highload-php-en" group.
>>>>>>> To unsubscribe from this group and stop receiving emails from it,
>>>>>>> send an email to highload-php-...@**googlegroups.com.
>>>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>>>> .
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>> --
>>>>>>
>>>>>> ---
>>>>>> You received this message because you are subscribed to the Google
>>>>>> Groups "highload-php-en" group.
>>>>>> To unsubscribe from this group and stop receiving emails from it,
>>>>>> send an email to highload-php-...@**googlegroups.com.
>>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>>> .
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>> --
>>>>>
>>>>> ---
>>>>> You received this message because you are subscribed to the Google
>>>>> Groups "highload-php-en" group.
>>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>>> an email to highload-php-...@**googlegroups.com.
>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>> .
>>>>>
>>>>>
>>>>>
>>>>
>>>> --
>>>
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "highload-php-en" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to highload-php-en+unsubscribe@googlegroups.com.
>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>
>>>
>>>
>> --
>>
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "highload-php-en" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to highload-php-en+unsubscribe@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>>
>>
>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Re: PHP Fatal error with nginx
August 05, 2013 02:22PM
Maintenance plugin, as sounds.

Thanks again!


On 5 August 2013 19:53, Przemysław Pawliczuk <p.pawliczuk@gmail.com> wrote:

> Which one it was?
> On Aug 5, 2013 3:24 PM, "Pablo Rodríguez González" <
> info@pablorodriguezgonzalez.es> wrote:
>
>> Thanks again!
>>
>> I can't see nothing special.
>>
>> Anyway, I've solved right now disabling a Wordpress plugin, incredible :(
>>
>> Best.
>>
>>
>> On 5 August 2013 12:40, Przemysław Pawliczuk <p.pawliczuk@gmail.com>wrote:
>>
>>> Use the output file param, then make request and kill the pool. After
>>> that open some kind of binary viewer and look for whole paths the worker is
>>> trying to open. There will be some I/O errors if they occur.
>>>
>>> AFAIR:
>>> ktrace -p PID -o output_file
>>> On Aug 4, 2013 9:55 PM, "Pablo Rodríguez" <
>>> info@pablorodriguezgonzalez.es> wrote:
>>>
>>>> Thanks!
>>>>
>>>> I haven't clear how to use it, because I suppose that I need to strace
>>>> the pid from php5-fpm, see the next:
>>>>
>>>> 21897 www-data 20 0 448m 105m 37m S 0.0 17.9 0:21.48
>>>> php5-fpm
>>>>
>>>> 21474 www-data 20 0 442m 99m 36m S 0.0 16.8 1:17.74
>>>> php5-fpm
>>>>
>>>> 21477 www-data 20 0 439m 96m 37m S 0.0 16.4 1:15.46 php5-fpm
>>>>
>>>> But when I do that I've nothing:
>>>>
>>>> root@socrates:/home/ubuntu# strace -p 21897
>>>> Process 21897 attached - interrupt to quit
>>>>
>>>> Any help would be appreciated.
>>>>
>>>> Best.
>>>>
>>>> El domingo, 4 de agosto de 2013 21:46:01 UTC+2, eRIZ escribió:
>>>>>
>>>>> Use ktrace/strace to verify, which OS' error is being produced. It's
>>>>> the most straight way to find out what's going on with paths or permissions.
>>>>>
>>>>>
>>>>> 2013/8/4 Pablo Rodríguez González <in...@pablorodriguezgonzalez.**es>
>>>>>
>>>>>> Thanks for your reply!
>>>>>>
>>>>>> Not, I'm not using a chrootred environment.
>>>>>>
>>>>>> Best.
>>>>>>
>>>>>>
>>>>>> On 4 August 2013 14:59, Przemysław Pawliczuk <p.paw...@gmail.com>wrote:
>>>>>>
>>>>>>> Are you using a chrooted env?
>>>>>>> On Aug 4, 2013 9:26 AM, "Pablo Rodríguez" <
>>>>>>> in...@pablorodriguezgonzalez.**es> wrote:
>>>>>>>
>>>>>>>> Hello!
>>>>>>>>
>>>>>>>> I'm having, in a PHP form, when I'm submiting one email, the next
>>>>>>>> error in error.log:
>>>>>>>>
>>>>>>>> 2013/08/03 21:39:22 [error] 19544#0: *11 FastCGI sent in stderr:
>>>>>>>> "PHP message: PHP Warning: require_once(TEMPLATEPATH/**
>>>>>>>> functions/theme-functions.php)**: failed to open stream: No such
>>>>>>>> file or directory in /web/domain.com/public/wp-**
>>>>>>>> content/themes/launcheffect/**functions.phphttp://domain.com/public/wp-content/themes/launcheffect/functions.phpon line 151
>>>>>>>>
>>>>>>>> PHP message: PHP Fatal error: require_once(): Failed opening
>>>>>>>> required 'TEMPLATEPATH/functions/theme-**functions.php'
>>>>>>>> (include_path='.:/usr/share/**php:/usr/share/pear') in /web/
>>>>>>>> domain.com/public/wp-**content/themes/launcheffect/**functions.phphttp://domain.com/public/wp-content/themes/launcheffect/functions.phpon line 151" while reading response header from upstream, client:
>>>>>>>> 71.28.74.212, server: www.domain.com, request: "POST
>>>>>>>> /wp-content/themes/**launcheffect/post.php HTTP/1.1", upstream:
>>>>>>>> "fastcgi://127.0.0.1:9000", host: "www.domain.com", referrer: "
>>>>>>>> http://www.domain.com/"
>>>>>>>>
>>>>>>>> I've been reading about permissions, about nginx and fastcgi, about
>>>>>>>> PHPfpm, reviewing my config...without success.
>>>>>>>>
>>>>>>>> Of course I've that file/directory.
>>>>>>>>
>>>>>>>> Can anyone help me to solve this error?
>>>>>>>>
>>>>>>>> Thanks in advance!
>>>>>>>>
>>>>>>>> --
>>>>>>>>
>>>>>>>> ---
>>>>>>>> You received this message because you are subscribed to the Google
>>>>>>>> Groups "highload-php-en" group.
>>>>>>>> To unsubscribe from this group and stop receiving emails from it,
>>>>>>>> send an email to highload-php-...@**googlegroups.com.
>>>>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>>>>> .
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>> --
>>>>>>>
>>>>>>> ---
>>>>>>> You received this message because you are subscribed to the Google
>>>>>>> Groups "highload-php-en" group.
>>>>>>> To unsubscribe from this group and stop receiving emails from it,
>>>>>>> send an email to highload-php-...@**googlegroups.com.
>>>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>>>> .
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>> --
>>>>>>
>>>>>> ---
>>>>>> You received this message because you are subscribed to the Google
>>>>>> Groups "highload-php-en" group.
>>>>>> To unsubscribe from this group and stop receiving emails from it,
>>>>>> send an email to highload-php-...@**googlegroups.com.
>>>>>> For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
>>>>>> .
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>> --
>>>>
>>>> ---
>>>> You received this message because you are subscribed to the Google
>>>> Groups "highload-php-en" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>> an email to highload-php-en+unsubscribe@googlegroups.com.
>>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>>
>>>>
>>>>
>>> --
>>>
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "highload-php-en" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to highload-php-en+unsubscribe@googlegroups.com.
>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>
>>>
>>>
>>
>> --
>>
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "highload-php-en" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to highload-php-en+unsubscribe@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>>
>>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 61
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready