Welcome! Log In Create A New Profile

Advanced

Re: Weird Problems of PHP-FPM Refusing Connections

Posted by Jr. Hames 
Jr. Hames
Re: Weird Problems of PHP-FPM Refusing Connections
July 19, 2013 01:32PM
I'm already using NGINX as well and I have the same issue. It does not seem
to be related to the workload, although, my server is very busy. I have
~1000 connections per minute. I tried updating my NGINX, my PHP-FPM, double
checked my code. Does anyone managed to solve the problem?

Cheers,
Jr. Hames

On Thursday, December 8, 2011 10:23:28 PM UTC-2, Adam J wrote:
>
> This sounds like the same issue I'm having. I'm already using nginx.
>
> On Nov 16, 11:29 am, 陈智宏 <zhihong.chen...@gmail.com> wrote:
> > In fact, it's not php's issue. Normally, lighttpd is crazy to dispatch
> all
> > workloads to
> >
> > Some of process, no matter what status is ,simple replace lighttpd with
> > nginx will resolve your issue.
> >
> > Lighttpd is very UN serious software.
> >
> >
> >
> >
> >
> >
> >
> > On Mon, Nov 14, 2011 at 3:39 PM, Alex Zhang <a...@osqdu.org> wrote:
> > > Forks,
> > > I manage a website with generally huge traffic. Currently I am using
> > > PHP-FPM 5.3.6 with lighttpd 1.4.29.
> > > The server seldom hangs (1 time / week), with the log similar with
> >
> > > 2011-11-13 23:42:14: (mod_fastcgi.c.3595) all handlers for /index.php?
> > > on .php are down.
> > > 2011-11-13 23:42:16: (mod_fastcgi.c.2762) fcgi-server re-enabled: 0 /
> > > dev/shm/php.socket
> > > 2011-11-13 23:42:17: (mod_fastcgi.c.2999) backend is overloaded; we'll
> > > disable it for 1 seconds and send the request to another backend
> > > instead: reconnects: 0 load: 567
> > > 2011-11-13 23:42:17: (mod_fastcgi.c.3595) all handlers for /index.php?
> > > on .php are down.
> > > 2011-11-13 23:42:19: (mod_fastcgi.c.2762) fcgi-server re-enabled: 0 /
> > > dev/shm/php.socket
> > > 2011-11-13 23:42:20: (mod_fastcgi.c.2999) backend is overloaded; we'll
> > > disable it for 1 seconds and send the request to another backend
> > > instead: reconnects: 0 load: 567
> >
> > > At first, I was using PHP-FPM which listens to 127.0.0.1:9000. Later,
> > > I found it always refusing connections upon peak hours, and I disabled
> > > backlog, which didn't help much. Finally, I moved to socket (/dev/shm/
> > > php.socket) and the server still hangs.
> >
> > > My PHP FPM log showed nothing with level of notice. When such problem
> > > happens, the load suddenly falls to 0.00, and PHP simply do not accept
> > > new connections. I have to kill PHP and restart it.
> > > I've got APC with PHP. PHP-FPM works in dynamic mode.
> >
> > > Please help me...
> >
> > > A...@OSQDU.org
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 50
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready