Welcome! Log In Create A New Profile

Advanced

nginx & curl - Error 502

Posted by Icemann3000 
nginx & curl - Error 502
June 11, 2013 01:30AM
Hello,

i´ve a big problem with nginx / php-fpm & curl:

I´am running multiple domains/vhosts with nginx.

On one vhost i will use curl to make requests from these vhost to another vhost on the same Server(!) via URL.

Previously i had the construct nginx (as proxy) -> apache -> php-fpm:
within these construct no problems occured.

After changing to nginx (as webserver) -> php-fpm i recieve errors in the error log.
Every request end immediately in an Error 502 (in the target Vhost Error Log)

I see in the error log:

2013/06/02 13:50:01 [error] 446#0: *74388 upstream sent unexpected FastCGI record: 3 while reading response header from upstream, client: 80.123.456.789, request: "GET /api/version? HTTP/1.1", upstream: "fastcgi://unix:/tmp/php5-fpm.sock:"

What could be the problem that it worked in my old configuration but with nginx only i ran into these error?

The mysterious is: if i do theses request from another server - it works. What´s the difference??

Is there something special to configure in nginx??

Would be great if someone had a possible solution for me.
I´ve tryed so much but nothing helped.

Kind regards,
Michael
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 44
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready