Welcome! Log In Create A New Profile

Advanced

Strange .ini file parsing

Posted by Anoop Alias 
Anoop Alias
Strange .ini file parsing
February 03, 2013 05:58AM
Hi,

I have a strange issue of php.fpm parsing a file ending in .ini whereas
this .ini file doesnt have anything to do with php

*26 FastCGI sent in stderr: "PHP message: WARNING: You have errors in you
INI file (/home/xxxxx/public_html/xxx/etc/xxxxx/magiczoomplus.settings.ini)
on line 1!"


I renamed the file and the error was gone .

So the question is - does php-fpm look for files ending in .ini ; if so how
to disable that and does this default behavior slow down things ?

Thanks
--
Anoop P Alias (PGP Key ID : 0x014F9953)
GNU system administrator
http://UniversalAdm.in

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Przemysław Pawliczuk
Re: Strange .ini file parsing
February 05, 2013 08:22AM
Don't you have the BOM in this file?

2013/2/3 Anoop Alias <anoopalias01@gmail.com>

> Hi,
>
> I have a strange issue of php.fpm parsing a file ending in .ini whereas
> this .ini file doesnt have anything to do with php
>
> *26 FastCGI sent in stderr: "PHP message: WARNING: You have errors in you
> INI file (/home/xxxxx/public_html/xxx/etc/xxxxx/magiczoomplus.settings.ini)
> on line 1!"
>
>
> I renamed the file and the error was gone .
>
> So the question is - does php-fpm look for files ending in .ini ; if so
> how to disable that and does this default behavior slow down things ?
>
> Thanks
> --
> Anoop P Alias (PGP Key ID : 0x014F9953)
> GNU system administrator
> http://UniversalAdm.in
>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Anoop Alias
Re: Strange .ini file parsing
February 05, 2013 08:58AM
On Tue, Feb 5, 2013 at 6:50 PM, Przemysław Pawliczuk
<p.pawliczuk@gmail.com>wrote:

> Don't you have the BOM in this file?
>
> 2013/2/3 Anoop Alias <anoopalias01@gmail.com>
>
>> Hi,
>>
>> I have a strange issue of php.fpm parsing a file ending in .ini whereas
>> this .ini file doesnt have anything to do with php
>>
>> *26 FastCGI sent in stderr: "PHP message: WARNING: You have errors in you
>> INI file (/home/xxxxx/public_html/xxx/etc/xxxxx/magiczoomplus.settings.ini)
>> on line 1!"
>>
>>
>> I renamed the file and the error was gone .
>>
>> So the question is - does php-fpm look for files ending in .ini ; if so
>> how to disable that and does this default behavior slow down things ?
>>
>> Thanks
>> --
>> Anoop P Alias (PGP Key ID : 0x014F9953)
>> GNU system administrator
>> http://UniversalAdm.in
>>
>> --
>>
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "highload-php-en" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to highload-php-en+unsubscribe@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>>
>>
>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "highload-php-en" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to highload-php-en+unsubscribe@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

I think its the conf file of a magento module and it has no relation to php
..


--
*Anoop P Alias*
GNUSYS http://gnusys.net

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Luck Piecuch
Re: Strange .ini file parsing
April 26, 2013 05:50AM
Same here - sometimes after restart FPM will take and parse some .ini file
from random user homedir instead of /usr/local/etc/php.ini
It's very hard to reproduce - but that's a serious security issue.

FreeBSD 9.1
PHP Version 5.3.24

'./configure' '--prefix=/usr/local'
'--with-config-file-path=/usr/local/etc' '--with-layout=GNU' '--enable-fpm'
'--with-zlib' '--with-iconv' '--with-pear'
'--with-libxml-dir=/usr/local/lib' '--enable-zip' '--with-gd'
'--with-jpeg-dir=/usr/local/lib' '--with-png-dir=/usr/local/lib'
'--with-freetype-dir=/usr/local/lib' '--with-zlib-dir=/usr/local/lib'
'--with-mysql=/usr/local' '--with-mysqli' '--with-pdo-mysql=/usr/local'
'--enable-bcmath' '--enable-calendar' '--with-curl' '--enable-dba'
'--enable-ftp' '--with-gettext' '--enable-magic-quotes' '--enable-mbstring'
'--with-mcrypt' '--with-mhash' '--with-openssl' '--enable-sockets'
'--with-imap' '--with-imap-ssl' '--with-kerberos'
'--with-xsl=/usr/local/lib' '--enable-exif' '--enable-soap'
'--enable-sqlite-utf8' '--with-tidy' '--with-ldap'



On Sunday, February 3, 2013 11:57:06 AM UTC+1, Anoop Alias wrote:
>
> Hi,
>
> I have a strange issue of php.fpm parsing a file ending in .ini whereas
> this .ini file doesnt have anything to do with php
>
> *26 FastCGI sent in stderr: "PHP message: WARNING: You have errors in you
> INI file (/home/xxxxx/public_html/xxx/etc/xxxxx/magiczoomplus.settings.ini)
> on line 1!"
>
>
> I renamed the file and the error was gone .
>
> So the question is - does php-fpm look for files ending in .ini ; if so
> how to disable that and does this default behavior slow down things ?
>
> Thanks
> --
> Anoop P Alias (PGP Key ID : 0x014F9953)
> GNU system administrator
> http://UniversalAdm.in
>

--

---
You received this message because you are subscribed to the Google Groups "highload-php-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to highload-php-en+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 156
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 500 on July 15, 2024
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready