Welcome! Log In Create A New Profile

Advanced

errors while building php...

Posted by tuxtoti 
tuxtoti
errors while building php...
May 09, 2009 03:53PM
Hi all,
I am getting the below errors when trying to build php(patched with
php-fpm)
>>

Undefined symbols:
"__fpm_event_init", referenced from:
_fpm_event_init_main in fpm_events.o
"__fpm_event_loop", referenced from:
_fpm_event_loop in fpm_events.o
"__fpm_event_get_method", referenced from:
_fpm_event_init_main in fpm_events.o
"_fcgi_set_in_shutdown", referenced from:
_fpm_php_soft_quit in fpm_php.o
"__fpm_event_base_free", referenced from:
_fpm_event_cleanup in fpm_events.o
"__fpm_event_add", referenced from:
_fpm_event_loop in fpm_events.o
_fpm_event_add in fpm_events.o
_fpm_pctl in fpm_process_ctl.o
_fpm_pctl_heartbeat in fpm_process_ctl.o
"__fpm_event_del", referenced from:
_fpm_event_del in fpm_events.o
_fpm_pctl in fpm_process_ctl.o
_fpm_pctl_action in fpm_process_ctl.o
_fpm_pctl_heartbeat in fpm_process_ctl.o
"_fcgi_set_mgmt_var", referenced from:
_fpm_php_init_child in fpm_php.o
_fpm_php_init_child in fpm_php.o
"__fpm_event_set", referenced from:
_fpm_event_loop in fpm_events.o
_fpm_event_add in fpm_events.o
_fpm_pctl in fpm_process_ctl.o
_fpm_pctl_heartbeat in fpm_process_ctl.o
"_fcgi_set_allowed_clients", referenced from:
_fpm_php_init_child in fpm_php.o
"__fpm_event_loopbreak", referenced from:
_fpm_event_exit_loop in fpm_events.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [libs/libphp5.bundle] Error 1

<<
configure options used:
./configure --prefix=/Users/tuxtoti/installs/ --mandir=/Users/tuxtoti/
installs/ --infodir=/Users/tuxtoti/installs/ --enable-fastcgi --enable-
fpm --with-apxs2=/usr/sbin/apxs --with-ldap=/usr --with-kerberos=/usr
--enable-cli --with-zlib-dir=/usr --enable-trans-sid --with-xml --
enable-exif --enable-ftp --enable-mbstring --enable-mbregex --enable-
dbx --enable-sockets --with-iodbc=/usr --with-curl=/usr --with-config-
file-path=/etc --sysconfdir=/private/etc --with-mysql-sock=/var/mysql
--with-mysqli=/usr/local/mysql-5.1.34-osx10.5-x86/bin/mysql_config --
with-mysql=/usr/local/mysql-5.1.34-osx10.5-x86/ --with-openssl=shared,/
opt/local --with-xmlrpc --with-xsl=/usr --with-pear --with-
iconv=shared,/opt/local

php version used:5.2.9
php-fpm version used: Latest 0.5.10 for php-5.2.8
build system: Mac OS 10.5.6

Any clue on whats happening?

Regards
Harish
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 44
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready