Welcome! Log In Create A New Profile

Advanced

[PATCH] Linux packages: documented lack of HTTP/3 support for older distros

Konstantin Pavlov
May 23, 2023 06:18PM
# HG changeset patch
# User Konstantin Pavlov <thresh@nginx.com>
# Date 1684878839 25200
# Tue May 23 14:53:59 2023 -0700
# Node ID 3ba229c95e50b7a422f8a61db7560d40bc6524db
# Parent 46b1da35ceeb697431de877cf43681b186617335
Linux packages: documented lack of HTTP/3 support for older distros.

diff -r 46b1da35ceeb -r 3ba229c95e50 xml/en/linux_packages.xml
--- a/xml/en/linux_packages.xml Tue May 23 19:36:24 2023 +0300
+++ b/xml/en/linux_packages.xml Tue May 23 14:53:59 2023 -0700
@@ -7,7 +7,7 @@
<article name="nginx: Linux packages"
link="/en/linux_packages.html"
lang="en"
- rev="85">
+ rev="86">

<section name="Supported distributions and versions" id="distributions">

@@ -179,6 +179,12 @@ versions:
</table>
</para>

+<para>
+Packages for RHEL 7 and SLES 12 are built without
+<link doc="docs/http/ngx_http_v3_module.xml">HTTP/3 support</link>
+because OpenSSL used by those doesn't support TLSv1.3.
+</para>
+
</section>


diff -r 46b1da35ceeb -r 3ba229c95e50 xml/ru/linux_packages.xml
--- a/xml/ru/linux_packages.xml Tue May 23 19:36:24 2023 +0300
+++ b/xml/ru/linux_packages.xml Tue May 23 14:53:59 2023 -0700
@@ -7,7 +7,7 @@
<article name="nginx: пакеты для Linux"
link="/ru/linux_packages.html"
lang="ru"
- rev="85">
+ rev="86">

<section name="Поддерживаемые дистрибутивы и версии" id="distributions">

@@ -179,6 +179,12 @@
</table>
</para>

+<para>
+Пакеты для RHEL 7 и SLES 12 собраны без
+<link doc="docs/http/ngx_http_v3_module.xml">поддержки HTTP/3</link>,
+так как OpenSSL, используемая в этих дистрибутивах, не поддерживает TLSv1.3.
+</para>
+
</section>


_______________________________________________
nginx-devel mailing list
nginx-devel@nginx.org
https://mailman.nginx.org/mailman/listinfo/nginx-devel
Subject Author Views Posted

[PATCH] Linux packages: documented lack of HTTP/3 support for older distros

Konstantin Pavlov 209 May 23, 2023 06:18PM

Re: [PATCH] Linux packages: documented lack of HTTP/3 support for older distros

Maxim Konovalov 100 May 23, 2023 07:56PM



Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 87
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready