Welcome! Log In Create A New Profile

Advanced

[nginx] SSL: silenced warnings when building with OpenSSL 3.0.

Maxim Dounin
November 16, 2021 09:56AM
details: https://hg.nginx.org/nginx/rev/7b79f0944197
branches: stable-1.20
changeset: 7964:7b79f0944197
user: Sergey Kandaurov <pluknet@nginx.com>
date: Tue Aug 10 23:43:16 2021 +0300
description:
SSL: silenced warnings when building with OpenSSL 3.0.

The OPENSSL_SUPPRESS_DEPRECATED macro is used to suppress deprecation warnings.
This covers Session Tickets keys, SSL Engine, DH low level API for DHE ciphers.

Unlike OPENSSL_API_COMPAT, it works well with OpenSSL built with no-deprecated.
In particular, it doesn't unhide various macros in OpenSSL includes, which are
meant to be hidden under OPENSSL_NO_DEPRECATED.

diffstat:

src/event/ngx_event_openssl.h | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)

diffs (12 lines):

diff -r 9b9299494238 -r 7b79f0944197 src/event/ngx_event_openssl.h
--- a/src/event/ngx_event_openssl.h Tue Aug 10 23:43:16 2021 +0300
+++ b/src/event/ngx_event_openssl.h Tue Aug 10 23:43:16 2021 +0300
@@ -12,6 +12,8 @@
#include <ngx_config.h>
#include <ngx_core.h>

+#define OPENSSL_SUPPRESS_DEPRECATED
+
#include <openssl/ssl.h>
#include <openssl/err.h>
#include <openssl/bn.h>
_______________________________________________
nginx-devel mailing list
nginx-devel@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx-devel
Subject Author Views Posted

[nginx] SSL: silenced warnings when building with OpenSSL 3.0.

Maxim Dounin 72 November 16, 2021 09:56AM



Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 59
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready