Welcome! Log In Create A New Profile

Advanced

Re: test suite failure with 1.20.1

Hugo Lefeuvre
January 10, 2022 08:30AM
Hi Maxim,

On Sun, Jul 04, 2021 at 04:29:43AM +0300, Maxim Dounin wrote:
> Hello!
>
> On Sat, Jul 03, 2021 at 09:18:53AM +0100, Hugo Lefeuvre wrote:
>
> > I am trying to run the test suite, but it seems that, no matter how I build
> > Nginx, it systematically fails.
> >
> > It seems that, most (all?) of the time, tests fail because Nginx returns
> > 403 error codes, e.g.:
> >
> > ./ssi_waited.t ............................. 1/3
> > # Failed test 'waited non-active'
> > # at ./ssi_waited.t line 60.
> > # 'HTTP/1.1 403 Forbidden
> > # Server: nginx/1.21.0
> > # Date: Sat, 03 Jul 2021 08:06:00 GMT
> > # Content-Type: text/html
> > # Connection: close
> > #
> > # <html>
> > # <head><title>403 Forbidden</title></head>
> > # <body>
> > # <center><h1>403 Forbidden</h1></center>
> > # <hr><center>nginx/1.21.0</center>
> > # </body>
> > # </html>
> > # '
> > # doesn't match '(?^m:^xFIRSTxWAITEDxSECONDx$)'
> >
> > The runtime configuration is the default one from nginx-1.20.1.tar.gz
> > (conf/nginx.conf).
> >
> > I must be doing something wrong with the build or run time configuration,
> > but I cannot pinpoint what. Any idea?
>
> Test output suggests that you are testing nginx 1.21.0, not
> 1.20.1. It looks like you are testing the wrong nginx binary, not
> the one you think you are testing. This might be the reason, for
> example, if you have some 3rd party modules compiled in and these
> modules reject requests for some reason.
>
> For additional details try looking into test details - in
> particular, test suite can leave full test configuration and logs
> for you with TEST_NGINX_LEAVE environment variable set, or simply
> cat the error log to the terminal before removing files with
> TEST_NGINX_CATLOG. See README of the test suite for details.

Sorry for the late answer, but better late than never!

The reason was that I was running the test suite as root. Switching to a
non-root user did the trick. I was indeed trying to run 1.21.1, not 1.20.1,
that was a typo in the title.

I think that the test suite README should mention that it cannot be run as
root.

Thanks for your answer!

Best,
Hugo

--
Hugo Lefeuvre (hle) | www.owl.eu.com
RSA4096_ 360B 03B3 BF27 4F4D 7A3F D5E8 14AA 1EB8 A247 3DFD
ed25519_ 37B2 6D38 0B25 B8A2 6B9F 3A65 A36F 5357 5F2D DC4C
_______________________________________________
nginx-devel mailing list
nginx-devel@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx-devel
Subject Author Views Posted

test suite failure with 1.20.1

Hugo Lefeuvre 451 July 03, 2021 04:20AM

Re: test suite failure with 1.20.1

Maxim Dounin 158 July 03, 2021 09:30PM

Re: test suite failure with 1.20.1

Hugo Lefeuvre 113 January 10, 2022 08:30AM

Re: test suite failure with 1.20.1

Maxim Dounin 76 January 10, 2022 06:06PM

Re: test suite failure with 1.20.1

Hugo Lefeuvre 135 January 14, 2022 10:30AM



Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 110
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready