Maxim Dounin
October 01, 2018 08:34AM
Hello!

On Sat, Sep 29, 2018 at 08:29:56AM +0700, Dewangga Alam wrote:

> Currently, I am using nginx-1.8.1 in production. And I need SPDY to
> works on nginx-1.14.0 co-exists with http/2. Because I still need SPDY
> for compatibility, and for future deployment, I will migrate it all to
> HTTP/2.
>
> To make this possible, so I was create patch to make SPDY and HTTP/2 run
> together.
>
> I was read cloudflare patch regarding this issue (spdy & http/2) and
> make some adjustment (patch attached).
>
> But, got some errors when compiling. The error message was :

[...]

Just to make sure you understand it:

As per https://caniuse.com/#search=spdy - SPDY is only supported
by about 20% of browsers in use, and most of these browsers
already support HTTP/2. Most modern browsers do not have SPDY
support.

In contrast, HTTP/2 is supported by more than 80% of browsers in
use. And most modern browsers which do not support HTTP/2 - do not
support SPDY either.

Moreover, SPDY code you are trying to bring back is not maintained
for a long time now, since it was replaced by HTTP/2 in nginx
1.9.5. And there are various known problems fixed in the HTTP/2
code since then, so likely there are similar problems in the SPDY
code.

Summing the above, trying to bring back SPDY support is mostly
meaningless and might be dangerous. It might be a better idea to
focus on migrating to HTTP/2 instead.

--
Maxim Dounin
http://mdounin.ru/
_______________________________________________
nginx-devel mailing list
nginx-devel@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx-devel
Subject Author Views Posted

Re: Bring SPDY back in nginx-1.14.0

Maxim Dounin 190 October 01, 2018 08:34AM

Re: Bring SPDY back in nginx-1.14.0

dewanggaba 129 October 01, 2018 12:16PM



Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 70
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready