Sirsiwal, Umesh
December 30, 2010 03:56PM
All,
I am trying to use the eval module with the following simple configuration. I am using agentzh's version of the eval module. The configuration is simple and is below. This configuration serves yahoo.com main page with nginx version 0.8.41. But with 0.8.54 (which should have eval bug fixed) the connection hangs for ever. I tried the patch with 0.8.53 with the same result.

Is this supposed to work?

-Umesh

location /eval/ {
rewrite /eval(.*)$ $1 break;
eval $res {
set $memc_key $host:$request_uri;
set $memc_value 1;
set $memc_cmd incr;
memc_pass 127.0.0.1:11211;
}
resolver 10.40.6.72;
proxy_pass http://www.yahoo.com/;
}

_______________________________________________
nginx-devel mailing list
nginx-devel@nginx.org
http://nginx.org/mailman/listinfo/nginx-devel
Subject Author Views Posted

Does Eval Module work Now?

Sirsiwal, Umesh 2637 December 30, 2010 03:56PM

Re: Does Eval Module work Now?

agentzh 797 December 30, 2010 10:16PM

RE: Does Eval Module work Now?

Sirsiwal, Umesh 849 December 31, 2010 10:44AM

RE: Does Eval Module work Now?

Sirsiwal, Umesh 859 January 01, 2011 11:12PM

Re: Does Eval Module work Now?

agentzh 959 January 03, 2011 10:26PM

Re: Does Eval Module work Now?

agentzh 782 January 01, 2011 11:34PM

Re: Does Eval Module work Now?

agentzh 932 January 05, 2011 11:54PM

RE: Does Eval Module work Now?

Sirsiwal, Umesh 815 January 10, 2011 03:32PM

Re: Does Eval Module work Now?

agentzh 869 January 11, 2011 02:26AM

Re: Does Eval Module work Now?

agentzh 885 January 12, 2011 12:06AM

RE: Does Eval Module work Now?

Sirsiwal, Umesh 1203 January 12, 2011 09:30AM



Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 138
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready