Welcome! Log In Create A New Profile

Advanced

[nginx-ru-announce] nginx security advisory (CVE-2024-31079, CVE-2024-32760, CVE-2024-34161, CVE-2024-35200)

Posted by Sergey Kandaurov 
Hello!

В реализации HTTP/3 в nginx были обнаружены четыре проблемы, которые
позволяют атакующему с помощью специально созданной QUIC-сессии вызвать
падение рабочего процесса (CVE-2024-31079, CVE-2024-32760, CVE-2024-35200),
отправку клиенту части содержимого памяти рабочего процесса на системах
с MTU больше 4096 байт (CVE-2024-34161), а также потенциально могут иметь
другие последствия (CVE-2024-31079, CVE-2024-32760).

Проблемам подвержен nginx, если он собран с экспериментальным модулем
ngx_http_v3_module (по умолчанию не собирается) и в конфигурационном
файле используется параметр quic директивы listen.

Проблемам подвержен nginx 1.25.0-1.25.5, 1.26.0.
Проблемы исправлены в nginx 1.27.0, 1.26.1.

Спасибо Nils Bars из CISPA.


--
Sergey Kandaurov

_______________________________________________
nginx-ru-announce mailing list
nginx-ru-announce@nginx.org
https://mailman.nginx.org/mailman/listinfo/nginx-ru-announce
Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 218
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 466 on July 09, 2024
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready