Welcome! Log In Create A New Profile

Advanced

[nginx-announce] nginx security advisory (CVE-2022-41741, CVE-2022-41742)

Posted by Maxim Dounin 
Hello!

Two security issues were identified in the ngx_http_mp4_module, which might
allow an attacker to cause a worker process crash or worker process memory
disclosure by using a specially crafted mp4 file, or might have potential
other impact (CVE-2022-41741, CVE-2022-41742).

The issues only affect nginx if it is built with the ngx_http_mp4_module
(the module is not built by default) and the "mp4" directive is used in
the configuration file. Further, the attack is only possible if an
attacker is able to trigger processing of a specially crafted mp4 file
with the ngx_http_mp4_module.

The issues affect nginx 1.1.3+, 1.0.7+.
The issues are fixed in 1.23.2, 1.22.1.

Patch for the issues can be found here:

http://nginx.org/download/patch.2022.mp4.txt


--
Maxim Dounin
http://nginx.org/
_______________________________________________
nginx-announce mailing list -- nginx-announce@nginx.org
To unsubscribe send an email to nginx-announce-leave@nginx.org
Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 91
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready