Welcome! Log In Create A New Profile

Advanced

[nginx-announce] nginx-1.14.2

Posted by Maxim Dounin 
Maxim Dounin
[nginx-announce] nginx-1.14.2
December 04, 2018 10:08AM
Changes with nginx 1.14.2 04 Dec 2018

*) Bugfix: nginx could not be built by gcc 8.1.

*) Bugfix: nginx could not be built on Fedora 28 Linux.

*) Bugfix: in handling of client addresses when using unix domain listen
sockets to work with datagrams on Linux.

*) Change: the logging level of the "http request", "https proxy
request", "unsupported protocol", "version too low", "no suitable key
share", and "no suitable signature algorithm" SSL errors has been
lowered from "crit" to "info".

*) Bugfix: when using OpenSSL 1.1.0 or newer it was not possible to
switch off "ssl_prefer_server_ciphers" in a virtual server if it was
switched on in the default server.

*) Bugfix: nginx could not be built with LibreSSL 2.8.0.

*) Bugfix: if nginx was built with OpenSSL 1.1.0 and used with OpenSSL
1.1.1, the TLS 1.3 protocol was always enabled.

*) Bugfix: sending a disk-buffered request body to a gRPC backend might
fail.

*) Bugfix: connections with some gRPC backends might not be cached when
using the "keepalive" directive.

*) Bugfix: a segmentation fault might occur in a worker process if the
ngx_http_mp4_module was used on 32-bit platforms.


--
Maxim Dounin
http://nginx.org/
_______________________________________________
nginx-announce mailing list
nginx-announce@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx-announce
Sorry, you do not have permission to post/reply in this forum.

Online Users

Guests: 65
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready