Welcome! Log In Create A New Profile

Advanced

Re: php-fpm 0.6.0.2

Posted by alekciy 
alekciy
Re: php-fpm 0.6.0.2
September 23, 2009 12:12PM
Thanks for comment. In the near future plan dynamic workers (Apache
like style)?

On 19 сен, 01:05, dreamcat4 <dreamc...@gmail.com> wrote:
> On Aug 16, 7:52 am, "Alexey A. Rybak" <alexey.ry...@gmail.com> wrote:
>
> > вот если бы найт написал сюда статус и свое видение проекта - было бы здорово.
>
> Hi -RU List,
>
> Current project status:
>
> In Andrei's absence we have matured the 0.6.0.2 version with bugfixes
> and improved configuration. The newest unofficial version is 0.6.5,
> which was finished just today. The reason for the configuration work
> has been to make it easier to package into a .rpm or .deb.
>
> After asking the Debian and Ubuntu maintainers, they replied that it
> will only be accepted into their Linux if we had included it in the
> PHP src code. So 0.6.5 has 2 sets of configuration, and a revised
> directory structure that can be used either way. The PHP developers
> have been sent this for integration upstream, and at this moment we
> are hoping for somebody to take an interest higher up.
>
> Until then, please anybody are welcome to use any fpm version 0.6.3+.
> These version contain important segfault and other bugfix since
> 0.6.0.2. The 0.6.3+ or higher will all work well with php 5.2.10+ and
> higher. Compilation is very simple, just see the readme.markdown file
> or run the generate-fpm-patch shell script.
>
> Best regards,
>
> dreamcat4
> dreamc...@gmail.com
dreamcat4
Re: php-fpm 0.6.0.2
September 24, 2009 04:50PM
2009/9/23 alekciy <alekciysyn@gmail.com>:
>
> Thanks for comment. In the near future plan dynamic workers (Apache
> like style)?

No but i have seen something like that recently in the litespeed php sapi.
However the litespeed php sapi doesn't support fcgi protocol (Fast-CGI).

There are many new sapis coming in php 5.3.2

dreamcat4
dreamcat4@gmail.com
Re: php-fpm 0.6.0.2
September 28, 2009 05:02AM
Поимел проблему с 0.6

1 Сгенерировал патч для 5.2.11
2 Пропатчил php
3 Собрал/установил php
4 Пробую запустить php-fpm

php-cgi --fpm --fpm-config /etc/php-fpm.conf

получаю ошибку и список опций
[code]
Error in argument 1, char 1: no argument for option -
Usage: php-cgi [-q] [-h] [-s] [-v] [-i] [-f ]
php-cgi [args...]
-a Run interactively
-b
| Bind Path for external FASTCGI Server mode
-C Do not chdir to the script's directory
-c | Look for php.ini file in this directory
-n No php.ini file will be used
-d foo[=bar] Define INI entry foo with value 'bar'
-e Generate extended information for debugger/profiler
-f Parse . Implies `-q'
-h This help
-i PHP information
-l Syntax check only (lint)
-m Show compiled in modules
-q Quiet-mode. Suppress HTTP Header output.
-s Display colour syntax highlighted source.
-v Version number
-w Display source with stripped comments and whitespace.
-z Load Zend extension .
-T Measure execution time of script repeated times.
[/code]

у меня проблема со зрением или действительно сменились параметры запуска ?


пробую запустить
php-cgi -f /etc/php-fpm.conf или php-cgi /etc/php-fpm.conf
получаю

[code]
PHP Parse error: syntax error, unexpected T_STRING in /etc/php-fpm.conf on line 1
[/code]

Где собака порылась и как подсунуть php-fpm конфигурационный файл ? Официальный сайт и гугл молчат как партизаны.
Владимир Стафиевский
Re: php-fpm 0.6.0.2
September 28, 2009 02:06PM
Поддержка fpm просто не собралась, на скок я понимаю. После ./configure не
обращали внимания написало ли нечто вроде "Unknow options --enable-fpm,
--enable fast-cgi" ?

28 сентября 2009 г. 13:02 пользователь "Денис" <nginx-forum@nginx.us>написал:

> Поимел проблему с 0.6
>
> 1 Сгенерировал патч для 5.2.11
> 2 Пропатчил php
> 3 Собрал/установил php
> 4 Пробую запустить php-fpm
>
> php-cgi --fpm --fpm-config /etc/php-fpm.conf
>
> получаю ошибку и список опций
>
> Error in argument 1, char 1: no argument for option -
> Usage: php-cgi [-q] [-h] [-s] [-v] [-i] [-f ]
> php-cgi
> -a Run interactively
> -b
> | Bind Path for external FASTCGI Server mode
> -C Do not chdir to the script's directory
> -c | Look for php.ini file in this directory
> -n No php.ini file will be used
> -d foo[=bar] Define INI entry foo with value 'bar'
> -e Generate extended information for debugger/profiler
> -f Parse . Implies `-q'
> -h This help
> -i PHP information
> -l Syntax check only (lint)
> -m Show compiled in modules
> -q Quiet-mode. Suppress HTTP Header output.
> -s Display colour syntax highlighted source.
> -v Version number
> -w Display source with stripped comments and whitespace.
> -z Load Zend extension .
> -T Measure execution time of script repeated times.
>
>
> у меня проблема со зрением или действительно сменились параметры запуска ?
>
>
> пробую запустить
> php-cgi -f /etc/php-fpm.conf или php-cgi /etc/php-fpm.conf
> получаю
>
>
> PHP Parse error: syntax error, unexpected T_STRING in /etc/php-fpm.conf on
> line 1
>
>
> Где собака порылась и как подсунуть php-fpm конфигурационный файл ?
> Официальный сайт и гугл молчат как партизаны.
>
> Posted at Nginx Forum:
> http://forum.nginx.org/read.php?25,8657,9645#msg-9645
>
>


--
С уважением,

Владимир Стафиевский
dreamcat four
Re: php-fpm 0.6.0.2
September 28, 2009 03:40PM
Hello,
If anyone can help translate this to Russian, they are very welcome:

http://github.com/dreamcat4/php-fpm/blob/master/readme.markdown

Best regards,

dreamcat4
dreamcat4@gmail.com

2009/9/28 Владимир Стафиевский <justdewil@gmail.com>:
> Поддержка fpm просто не собралась, на скок я понимаю. После ./configure не
> обращали внимания написало ли нечто вроде "Unknow options --enable-fpm,
> --enable fast-cgi" ?
> --
> С уважением,
>
> Владимир Стафиевский
>
>
Re: php-fpm 0.6.0.2
September 28, 2009 11:43PM
Владимир спасибо, вы оказались правы.

Не совсем понятно, чем вызвано требование libevent >=1.4.12, многие дистрибутивы и RHEL в частности имеют с своем соcтаве старые версии этих либ, и сборка данного патча пользователями данных дистрибутивов будет невозможна, ведь на штатный в RHEL libevent 1.1a завязано очень много уже собранных приложений входящих как в состав самого дистрибутива, так и содержащихся в стороних репозиториях.
Alexey V. Karagodov
Re: php-fpm 0.6.0.2
September 29, 2009 05:08AM
потому что изначально фпм выходил со
своим libevent на борту, пропатченом если
не ошибаюсь в 3-х местах, со временем
ребята из команды libevent эти патчи стали
применять и вот результат - фпм требует
современного libevent


On 29.09.2009, at 7:43, Денис wrote:

> Владимир спасибо, вы оказались правы.
>
> Не совсем понятно, чем вызвано
> требование libevent >=1.4.12, многие
> дистрибутивы и RHEL в частности имеют с
> своем соcтаве старые версии этих либ,
> и сборка данного патча
> пользователями данных дистрибутивов
> будет невозможна, ведь на штатный в RHEL
> libevent 1.1a завязано очень много уже
> собранных приложений входящих как в
> состав самого дистрибутива, так и
> содержащихся в стороних репозиториях.
>
> Posted at Nginx Forum: http://forum.nginx.org/read.php?25,8657,9809#msg-9809
>
Ilyas --
Re: php-fpm 0.6.0.2
September 29, 2009 07:52AM
Соберите новый libevent и слинкуйте с ним php статично.



2009/9/29 "Денис" <nginx-forum@nginx.us>

> Владимир спасибо, вы оказались правы.
>
> Не совсем понятно, чем вызвано требование libevent >=1.4.12, многие
> дистрибутивы и RHEL в частности имеют с своем соcтаве старые версии этих
> либ, и сборка данного патча пользователями данных дистрибутивов будет
> невозможна, ведь на штатный в RHEL libevent 1.1a завязано очень много уже
> собранных приложений входящих как в состав самого дистрибутива, так и
> содержащихся в стороних репозиториях.
>
> Posted at Nginx Forum:
> http://forum.nginx.org/read.php?25,8657,9809#msg-9809
>
>


--
Ilyas R. Khasyanov
Unix/Linux System Administrator
GPG Key ID: 6EC5EB27 (Changed since 2009-05-12)
Re: php-fpm 0.6.0.2
September 29, 2009 12:06PM
Поимел пробему при сборке x86_64

CentOS 5
rpm -qa|grep libevent
[code]
libevent-devel-1.4.12-1.el5
libevent-1.4.12-1.el5
[/code]
ошибка
[code]
/BUILD/php-5.2.11/sapi/fpm/fpm/fpm_atomic.h:64:8: error: macro names must be identifiers
make: *** [sapi/fpm/fpm/fpm_request.lo] Error 1
make: *** Waiting for unfinished jobs....
/BUILD/php-5.2.11/Zend/zend_vm_execute.h: In function 'ZEND_HANDLE_EXCEPTION_SPEC_HANDLER':
BUILD/php-5.2.11/Zend/zend_vm_execute.h:531: warning: 'catch_op_num' may be used uninitialized in this function
[/code]

под i386 сборка проходит успешно.

configure
[code]
./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --target=x86_64-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --cache-file=../config.cache --with-libdir=lib64 --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.d --disable-debug --with-pic --disable-rpath --without-pear --with-bz2 --with-exec-dir=/usr/bin --with-freetype-dir=/usr --with-png-dir=/usr --with-xpm-dir=/usr --enable-gd-native-ttf --with-t1lib=/usr --without-gdbm --with-gettext --with-gmp --with-iconv --with-jpeg-dir=/usr --with-openssl --with-pcre-regex=/usr --with-zlib --with-layout=GNU --enable-exif --enable-ftp --enable-magic-quotes --enable-sockets --enable-sysvsem --enable-sysvshm --enable-sysvmsg --with-kerberos --enable-ucd-snmp-hack --enable-shmop --enable-calendar --without-mime-magic --without-sqlite --with-libxml-dir=/usr --enable-xml --with-system-tzdata --enable-force-cgi-redirect --enable-pcntl --with-imap=shared --with-imap-ssl --enable-mbstring=shared --enable-mbregex --with-ncurses=shared --with-gd=shared --enable-bcmath=shared --enable-dba=shared --with-db4=/usr --with-xmlrpc=shared --with-ldap=shared --with-ldap-sasl --with-mysql=shared,/usr --with-mysqli=shared,/usr/bin/mysql_config --enable-dom=shared --with-pgsql=shared --enable-wddx=shared --with-snmp=shared,/usr --enable-soap=shared --with-xsl=shared,/usr --enable-xmlreader=shared --enable-xmlwriter=shared --with-curl=shared,/usr --enable-fastcgi --enable-pdo=shared --with-pdo-odbc=shared,unixODBC,/usr --with-pdo-mysql=shared,/usr --with-pdo-pgsql=shared,/usr --with-pdo-sqlite=shared,/usr --with-pdo-dblib=shared,/usr --enable-json=shared --enable-zip=shared --with-readline --enable-dbase=shared --with-pspell=shared --with-mcrypt=shared,/usr --with-mhash=shared,/usr --with-tidy=shared,/usr --with-mssql=shared,/usr --enable-sysvmsg=shared --enable-sysvshm=shared --enable-sysvsem=shared --enable-posix=shared --with-unixODBC=shared,/usr --with-recode=shared,/usr --with-libevent=shared --with-fpm --with-fpm-bin=/usr/bin/php-cgi --with-fpm-port=9000 --with-fpm-conf=/etc/php-fpm.conf --with-fpm-log=/var/log/php-fpm.log --with-fpm-pid=/var/run/php-fpm.pid --with-fpm-user=nobody --with-fpm-group=nobody
[/code]
dreamcat four
Re: php-fpm 0.6.0.2
September 29, 2009 12:12PM
Перевод Анатолия Пашина
http://github.com/dreamcat4/php-fpm/blob/master/readme-ru.markdown

2009/9/28 dreamcat four <dreamcat4@gmail.com>:
> Hello,
> If anyone can help translate this to Russian, they are very welcome:
>
> http://github.com/dreamcat4/php-fpm/blob/master/readme.markdown
>
> Best regards,
>
> dreamcat4
> dreamcat4@gmail.com
dreamcat four
Re: php-fpm 0.6.0.2
September 29, 2009 01:38PM
https://bugs.launchpad.net/php-fpm/+bug/437085

On Tue, Sep 29, 2009 at 5:06 PM, "Денис" <nginx-forum@nginx.us> wrote:
>
> Поимел пробему при сборке x86_64
>
> CentOS 5
> rpm -qa|grep libevent
>
> libevent-devel-1.4.12-1.el5
> libevent-1.4.12-1.el5
>
> ошибка
>
> /BUILD/php-5.2.11/sapi/fpm/fpm/fpm_atomic.h:64:8: error: macro names must be identifiers
> make: ***  Error 1
> make: *** Waiting for unfinished jobs....
> /BUILD/php-5.2.11/Zend/zend_vm_execute.h: In function 'ZEND_HANDLE_EXCEPTION_SPEC_HANDLER':
> BUILD/php-5.2.11/Zend/zend_vm_execute.h:531: warning: 'catch_op_num' may be used uninitialized in this function
>
>
> под i386 сборка проходит успешно.
>
> configure
>
> ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --target=x86_64-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --cache-file=../config.cache --with-libdir=lib64 --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.d --disable-debug --with-pic --disable-rpath --without-pear --with-bz2 --with-exec-dir=/usr/bin --with-freetype-dir=/usr --with-png-dir=/usr --with-xpm-dir=/usr --enable-gd-native-ttf --with-t1lib=/usr --without-gdbm --with-gettext --with-gmp --with-iconv --with-jpeg-dir=/usr --with-openssl --with-pcre-regex=/usr --with-zlib --with-layout=GNU --enable-exif --enable-ftp --enable-magic-quotes --enable-sockets --enable-sysvsem --enable-sysvshm --enable-sysvmsg --with-!
>  kerberos --enable-ucd-snmp-hack --enable-shmop --enable-calendar --without-mime-magic --without-sqlite --with-libxml-dir=/usr --enable-xml --with-system-tzdata --enable-force-cgi-redirect --enable-pcntl --with-imap=shared --with-imap-ssl --enable-mbstring=shared --enable-mbregex --with-ncurses=shared --with-gd=shared --enable-bcmath=shared --enable-dba=shared --with-db4=/usr --with-xmlrpc=shared --with-ldap=shared --with-ldap-sasl --with-mysql=shared,/usr --with-mysqli=shared,/usr/bin/mysql_config --enable-dom=shared --with-pgsql=shared --enable-wddx=shared --with-snmp=shared,/usr --enable-soap=shared --with-xsl=shared,/usr --enable-xmlreader=shared --enable-xmlwriter=shared --with-curl=shared,/usr --enable-fastcgi --enable-pdo=shared --with-pdo-odbc=shared,unixODBC,/usr --with-pdo-mysql=shared,/usr --with-pdo-pgsql=shared,/usr --with-pdo-sqlite=shared,/usr --with-pdo-dblib=shared,/usr --enable-json=shared --enable-zip=shared --with-readline --enable-dbase=shared --with-psp!
>  ell=shared --with-mcrypt=shared,/usr --with-mhash=shared,/usr !
>  --with-t
> idy=shared,/usr --with-mssql=shared,/usr --enable-sysvmsg=shared --enable-sysvshm=shared --enable-sysvsem=shared --enable-posix=shared --with-unixODBC=shared,/usr --with-recode=shared,/usr --with-libevent=shared --with-fpm --with-fpm-bin=/usr/bin/php-cgi --with-fpm-port=9000 --with-fpm-conf=/etc/php-fpm.conf --with-fpm-log=/var/log/php-fpm.log --with-fpm-pid=/var/run/php-fpm.pid --with-fpm-user=nobody --with-fpm-group=nobody
>
>
> Posted at Nginx Forum: http://forum.nginx.org/read.php?25,8657,9975#msg-9975
>
>
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 77
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready